BeagleBone Black: failed to load driver tilcdc

I just flashed my BBB with the following image :
AM335x 11.7 2023-09-02 4GB eMMC IoT Flasher

I ran the following commands through an SSH session:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libsdl2-dev

After, I tried to compile an example code of the SDL library:

Install SDL on Linux, free tutorial (glusoft.com)

#include <SDL.h>

        int main() {
            if (SDL_Init(SDL_INIT_VIDEO) != 0) {
                printf("SDL_Init Error: %s\n", SDL_GetError());
                return 1;
            }
        
            SDL_Window* window = SDL_CreateWindow("Hello SDL", SDL_WINDOWPOS_CENTERED, SDL_WINDOWPOS_CENTERED, 640, 480, 0);
            if (window == NULL) {
                printf("SDL_CreateWindow Error: %s\n", SDL_GetError());
                return 1;
            }
        
            SDL_Renderer* renderer = SDL_CreateRenderer(window, -1, SDL_RENDERER_ACCELERATED);
            if (renderer == NULL) {
                printf("SDL_CreateRenderer Error: %s\n", SDL_GetError());
                return 1;
            }
        
            SDL_SetRenderDrawColor(renderer, 255, 255, 255, 255);
            SDL_RenderClear(renderer);
            SDL_RenderPresent(renderer);
        
            SDL_Delay(2000); // Wait for 2 seconds
        
            SDL_DestroyRenderer(renderer);
            SDL_DestroyWindow(window);
            SDL_Quit();
        
            return 0;
        }

On my laptop this creates a white window for 2 seconds and close the program.
However, on the bbb, this returned the following errors:

MESA-LOADER: failed to open tilcdc: /usr/lib/dri/tilcdc_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib/arm-linux-gnueabihf/dri:\$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
failed to load driver: tilcdc

Any idea how to solve it ?

Thanks,
Nicolas

Hello,
Welcome to the DigiKey tech forum. I’m not sure what may be causing your issue but I’m sure one of our engineers will be able to offer assistance.

If anyone else has the issue, just run the following command to resolve the error

sudo apt install bbb.io-xfce4-desktop

I thought I would not need a windows manager since I have a single graphical application I want to run on the beaglebone black.