Mentor Maker... PartsQuest parts missing symbols?


I downloaded, installed, and registered the free Mentor Maker design environment today. It took me a while to figure out how to use PartsQuest to select parts and import into Maker Schematic entry.


I downloaded five parts; one of them, an MMBT3904 transistor, worked fine, with both a symbol and a footprint… another part, BSP225, downloaded with a footprint… but the symbol was just a rectangle. Three other parts, all of them microcontrollers from Silicon Labs, gave me NO symbol or footprint… just a rectangle.

Obviously, this design environment would be relatively useless without both the symbol and the footprint. One of the microcontrollers was the Silabs C8051F314… can someone try that, and let me know if they successfully got both a symbol and a footprint?

Can anyone suggest what I might be doing wrong, if the problem is my own fault?



Just wanted to check and see if there are symbols associated with the parts you downloaded. I checked a couple that you mentioned and those didn’t have S&F associated.
Would you mind sharing a more detailed set of part numbers with me so I can investigate further?


OK, I have downloaded 7 parts, so far… all of them show up in the Maker application under ‘PartQuestDirect’. The parts are as follows (this is how they are labeled, in the ‘Parts’ window at the bottom of the Maker application)::


The last two are simple bipolar transistors, and in both cases, there is a symbol and a footprint. The first item (1727_1865) is a simple FET, and there’s a footprint, but the symbol is just a rectangle with three leads. The four remaining parts have no symbol or footprint, at all.

Now, there’s a disconnect between the part number, as described in the DigiKey catalog, and the name of the .pqz file which gets downloaded.

For example, I selected an inductor in Digikey:

The Digikey number is 811-2609-2ND
The downloaded file name for this part was PQDownload_190114_5435696.pqz

This file was only 4Kb in size. The only parts that contained both a symbol and a footprint (the two transistors) were 211Kb and 212Kb, respectively.

So, it appears that the parts that are without both symbol and footprint, as well as the one part that had a footprint, but no symbol, were the result of incomplete files.

Am I doing anything wrong?



@tidetracker I looked up all the parts that you listed on where everything is based. Only the first part and the last two have any symbol or footprint associated.
1727-1865-2-ND <—S&F from Symacsys on PartQuest
1727-5395-2-ND <-- no S&F
336-1257-ND <-- no S&F
336-2614-ND <-- no S&F
811-2609-2-ND <—S&F on
MMBT3904TPMSTR-ND <—S&F from Symacsys on PartQuest
MMBT3906-FDITR-ND <—S&F from Symacsys on PartQuest

I am not familiar with PartquestDirect at the moment and will have to spend some time and investigate what that is. My first suggestion would be to search parts on for a better experience and indication of what has footprints and what just has basic information.
From my experience the 4Kb parts are just part data and not S&F assets.
If you are getting some and not others you would likely be following the unzipping procedure correctly and know the correct tool selection.
So it sounds like the PartQuestDirect is portraying that these parts have S&F but they do not based on I would check on for other suppliers like Ultra Librarian or SnapEDA.

Let me know if you run into any other problems like this so we can get them corrected.
Thank you!


Jeremy, thanks for the response.

It does appear that there are numerous parts that I’m likely to use, which have no footprint or symbol associated with them. I tried SnapEDA, which appears to be the only other free database of parts that might be useful, but just like PartsQuest, a number of potential parts have either no symbol, or no footprint, or lack both. Furthermore, SnapEDA’s instructions for importing parts from their database, to PADS Maker, don’t work… the instructions call for activating the ‘File/Library’ menu item, but no such item exists in the version of PADS Maker I downloaded via links from DigiKey…

My reason for trying to use these tools: over my 45 year career, I’ve done circuit design, first with hand-drawn schematics, and then using ORCAD, before passing the schematics on to a layout engineer for the actual layout work. I figured that it might be time for me to begin doing the layout work, myself… presuming that the tools would be available which would eliminate the tedium of having to create schematic decals, as well as footprint graphics, by myself.

Sadly, it doesn’t look like the tools are quite that easy to use, as of yet. It’s a shame, since the PADS Maker program looked so promising.

Thanks again for your help.