PICO-PI-IMX7: Editing and Recovery/Linux 4.19.x


I followed those instructions. I used wget and then used tar and then I exported it.


P.S. Send guidance if you have time.

So did you open a “new” terminal, the export is only valid in the context of the current running shell/terminal window…


Hello Sir,

Probably. I will do it again. Sheesh. So much to learn.


P.S. Off to try again.

@RobertCNelson ,

I stay back and I stay trying do this: https://hub.mender.io/t/technexion-pico-imx7d-som/451

I need your help because technexion don’t more have paste Download here ftp://download.technexion.net/development_resources/Download/wifi_firmware/Broadcom/AP6335_4.2.tgz

And I need AP6335_4.2.tgz AND AP6212_4.2.tgz

Pls help-me

Looks like i archived these in my personal repo a few years back:



Sir, I am sorry. To this day and for some time now, I have been unable to help in this regards.

I sold my board, got rid of my records for the board, and I let go. Please forgive me.


Ok. I forgot u


Please, help me with this issue:

after saveenv command.
=> mmc list
=> part list mmc 0
“## Unknown partition table type 0”
=> part list mmc 1
MMC Device 1 not found

dfu 0 mmc 0
Couldn’t find part #1 on mmc device #0
DFU entities configuration failed!
(partition table does not match dfu_alt_info?)
dfu - Device Firmware Upgrade

dfu <USB_controller> [list]

  • device firmware upgrade via <USB_controller>
    on device , attached to interface

[list] - list available alt settings

I stay trying this:

ums 0 mmc 0

Next, on your development machine: (replace DISK with /dev/sdX, look at lsblk and use the new driver that’s the pico…)
sudo dd if=/dev/zero of=${DISK} bs=1M count=10

sudo sfdisk ${DISK} <<-EOF

sudo mkfs.ext4 -L rootfs ${DISK}1

*BUT my Yocto .sdimg image not working, Why

How are you writing your sdimg file?

As after running:

ums 0 mmc 0

Just run this on your Development PC:

sudo dd if=./core-file-sdimg of=${DISK}



I need mmc partconf 0 0 7 0 or not?
(with ou without this I have issue with dfu 0 mmc 0)

I tried without mmc partconf and I have new issues

Please look result to printenv, mmc list and ums 0 mmc 0
(I can’t flash in mmc 0 yet)

What version of u-boot?

In U-Boot type:



=> version
U-Boot 2015.04-00077-g678c1cf (Feb 10 2017 - 10:16:36)
arm-linux-androideabi-gcc (GCC) 4.9 20150123 (prerelease)
GNU ld (GNU Binutils)

  1. I have an other question:
    I usually have to flash the image (* .sdimg in this case) after or before I put the jumpers in Boot Normal Mode? (This tutorial is having the image recorded after it put jumpers in Normal Boot Mode.

That is NXP’s version of u-boot. That’s why we use mainline u-boot:


If that’s what they require, it looks like the use imx_usb_loader to transfer everything with their directions. Where we use u-boot to do most of it.


@RobertCNelson please

U said : That is NXP’s version of u-boot. That’s why we use mainline u-boot:

  1. Can’t I use the version I’m using? It will not work ?

  2. What about mmc partconf 0 0 7 0 command? This command is essential? Or not

Sorry, i didn’t have much luck with NXP’s version with usb.

ums 0 mmc 0

the 7 enables: boot_partition_enable, we need that with mainline. This allows us to directly write the SPL/u-boot.img to the eMMC.


@RobertCNelson After I RUN sudo dfu-util -D SPL -a spl AND
sudo dfu-util -D u-boot.img -a u-boot COMMANDS I can’t run more ums 0 mmc 0. Before, I run mmc list and I have this result: mmc list
FSL_SDHC: 0 (eMMC). Why ?

With mmc partconf 0 0 7 0 I can !!! But not solved yet

I don’t know, what version of u-boot are you using?

On mainline:

=> version
U-Boot 2020.07 (Jul 29 2020 - 11:55:38 -0500)

arm-linux-gnueabihf-gcc (Linaro GCC 6.5-2018.12) 6.5.0
GNU ld (Linaro_Binutils-2018.12)
=> mmc list

The “0 eMMC” is the only useful mmc device for what we need.

In u-boot all 3 are defined in the device tree:

Here is where u-boot get’s the eMMC define from:


At this moment, as it was at the end of 2019, I managed to climb Yocto, in a game that I want to overcome. I recorded it after mmc partconf 0 0 7 0 and it didn’t go up. I returned the jumpers to the download mode and rewrote SPL and u-boot (from 2015, probably). I have this photo below:
e.g. (only goes up in download mode and with some instabilities)

What is your plan with this device, to run Yocto, or Debian/Ubuntu, or Android, or something else?

If your using Yocto, you should follow the directions presented on the mender.io website. It looks like they have a forum, so you should be able to ask follow up questions on their directions.

If your planning on using Debian/Ubuntu, just follow our directions as written.



@RobertCNelson https://mender.io/blog/mender-and-google-cloud-iot-core-reference-integration

I’m Actions on google specialist !

I put apt-get and opkg (package manager/local.conf) But not stay in Yocto (damaged and running in download mode only)