PPPs for setting metric

Hi Robert,

When I connect PPP network for cellular modem, the pppd sets default routing IPs into route table. I tried to add metric into routing IPs entries added, but it fails. From

https://bugs.gentoo.org/704722
pppd.sh: ppp-2.4.8 introduced “defaultroute-metric” option

But the buster version can only install pppd-2.4.7. (On this version, it considers the above option as invalid)
Not sure you can help me to patch the bug fix for buster release, too?

Thank you for your help,

David Zhou

Oh, there are some fun changes in ppp 2.4.8…

dh_auto_build: make -j2 "COPTS=-g -O2 -fdebug-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2" "LDOPTS=-Wl,-z,relro -Wl,-z,now" dh_auto_build -Dpppd-udeb/ -- "COPTS=-g -O2 -fdebug-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -Os -fomit-frame-pointer" "LDOPTS=-Wl,-z,relro -Wl,-z,now" CHAPMS= USE_CRYPT= NO_CRYPT_HACK=1 MPPE= FILTER= HAVE_MULTILINK= USE_TDB= HAS_SHADOW= USE_PAM= HAVE_INET6= CBCP= USE_SRP= MAXOCTETS= USE_BUILTIN_CRYPTO=1 USE_EAPTLS= returned exit code 2
make[1]: *** [debian/rules:81: override_dh_auto_build-arch] Error 2
make[1]: Leaving directory '/<<PKGBUILDDIR>>'
make: *** [debian/rules:35: build] Error 2

Regards,

Hi Robert,
That’s too bad. I am trying something else. If it works, then I don’t need to update to a new version.

Best Regards,

David

Hi Robert,
I created a script to remove routing table entries and then added back with custom settings. So, I am ok with 2.4.7 version.

Thank you very much,
David