RE: PICO-PI-IMX7 and Siging In/Um?


#86

why?

No, can you get to u-boot prompt?

Regards,


#87

Yes Sir,

I can get to u-boot in USB Boot Mode.

Seth

P.S. Oh and sir, the reason I used sdb0 was b/c of this line in the instructions, " Example: for DISK=/dev/mmcblkX, when X was 0 in the old instruction log. I just thought I could exchange X (0) from mmcblk0 to sdb0. That is the answer. My fault. I know now.


#88

Okay, do this again:

First run on the Pico:

ums 0 mmc 0

Next, on your development machine: (replace DISK with /dev/sdX, look at lsblk and use the new driver that’s the pico…)

sudo dd if=/dev/zero of=${DISK} bs=1M count=10

sudo sfdisk ${DISK} <<-__EOF__
1M,,L,*
__EOF__

sudo mkfs.ext4 -L rootfs ${DISK}1

Now in u-boot kill the “ums 0 mmc 0” and rerun the “dfu 0 mmc 0”…

The “/dev/mmcblkX” node is special when compare to a normal block device…

Normal Block devices go: /dev/sda -> /dev/sdb -> /dev/sdc, with partitions starting with “1, 2, 3…”

Where as the “/dev/mmcblkX” devices goes: /dev/mmcblk0 -> /dev/mmcblk1 -> /dev/mmcblk2 with partitions starting, p1, p2, p3…

Regards,


#91

Sir,

sudo sfdisk ${DISK} <<-__EOF__
> 1m,,L,*
> __EOF__
Checking that no-one is using this disk right now ... FAILED

This disk is currently in use - repartitioning is probably a bad idea.
Umount all file systems, and swapoff all swap partitions on this disk.
Use the --no-reread flag to suppress this check.

sfdisk: Use the --force flag to overrule all checks.

Seth

P.S. This is when I run: sudo sfdisk ${DISK} <<-EOF and I have gotten this error before. I tried things I know but I have failed so far.


#92

@silver2row, have you disabled your kde/gnome/xfce/cinnamon/lxqt’s auto drive mounter?

Regards,


#93

No sir,

I have not done that yet. I will get on it.

Seth


#94

Sir,

Do I need to build the Linux Kernel every time I make errors w/ the instructions or is it there for future use, as is?

Seth

P.S. I removed automount in my Ubuntu Desktop. I guess I will restart the machine and see if it took place.


#95

Sir,

Well, I have a new error:

Checking that no-one is using this disk right now ... OK

Disk /dev/sdb: 539.5 KiB, 552448 bytes, 1079 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

>>> Created a new DOS disklabel with disk identifier 0xd5747866.
/dev/sdb1: Start sector 2048 out of range.
Failed to add #1 partition: Numerical result out of range
Leaving.

This is w/ the cmd in the dev. desktop: sudo sfdisk ${DISK} <<-__EOF__

Seth

P.S. I am moving on from here and trying more items. If you come up w/ any ideas, please contact me when you have some time.


#96

@silver2row

Disk /dev/sdb: 539.5 KiB, 552448 bytes, 1079 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

So the “eMMC” on your PICO is now 539.5KiB in size…

umount the drive

sudo umount /dev/sdb

Fully unplug the PICO…

and delete the invalid device node…

sudo rm -rf /dev/sdb

and start again… It sounds like you dd’ed SPL/u-boot.img before you mounted the eMMC…

Regards,


#97

Yes Sir,

I tried to set up from scratch again. I am getting an error at dfu 0 mmc 0 in the u-boot console.

Seth

P.S. Here it is: I know we walked through this before. I erased/removed the /dev/sdb dir. and tried to umount the board but umount stated that the board was not mounted.

=> dfu 0 mmc 0
Couldn’t find part #1 on mmc device #0
DFU entities configuration failed!
(partition table does not match dfu_alt_info?)
dfu - Device Firmware Upgrade

Usage:
dfu <USB_controller> [list]

  • device firmware upgrade via <USB_controller>
    on device , attached to interface
    [list] - list available alt settings

#98
dfu 0 mmc 0
Couldn’t find part #1 on mmc device #0
DFU entities configuration failed!

DFU needs a valid partition, so do this again…

First run on the Pico:

ums 0 mmc 0

Next, on your development machine: (replace DISK with /dev/sdX, look at lsblk and use the new driver that’s the pico…)

sudo dd if=/dev/zero of=${DISK} bs=1M count=10

sudo sfdisk ${DISK} <<-__EOF__
1M,,L,*
__EOF__

sudo mkfs.ext4 -L rootfs ${DISK}1

Regards,


#99

Sir,

Should I perform the u-boot cmd ums 0 mmc 0 and then the commands below in your instructions and then try to sudo umount /dev/sdb and then sudo rm -rf /dev/sdb?

Seth


#100

It depends… If sfdisk reports the disk to be too small again, then yes…

Regards,


#101

Yes Sir,

Thank you…@RobertCNelson: Here is the command umount /dev/sdb on the dev. desktop terminal.

sudo umount /dev/sdb
umount: /dev/sdb: not mounted.

Seth

P.S. I have been reading on umount in the man pages. Should I load lazily, i.e. -l? I am sure you can tell, this is my first rodeo. Anyway, Where, if at any point, should I start on the instructions after I cannot umount my device?


#102

@silver2row, in u-boot type:

ums 0 mmc 0

Then on your PC, type:

sudo fdisk -l /dev/sdb | grep ^/dev

and report what you get…

Regards,


#103
sudo fdisk -1 /dev/sdb | grep ^/dev
fdisk: invalid option -- '1'
Try 'fdisk --help' for more information.

Sir, I think I just narrowed down the issue. Would it be -l (el) instead of -1 (one)? If not, that is using the -1 in the command you told me to use and stated in the above terminal printout.

Seth


#104

That was an “-l” as in list…

Ps: you can copy n paste from the browser.

Regards,


#105

Sir,

I think this is where I went wrong in the instructions: sudo sfdisk ${DISK} <<-__EOF__! After this command, I typed in 1M (as in one emm). Now, I think I may have had to type in or copy, lM (el emm). Am I right?

Seth

P.S. Here is the list from fdisk:

sudo fdisk -l /dev/sdb | grep ^/dev
/dev/sdb1  *     2048 7471103 7469056  3.6G 83 Linux

Those l’s look like 1’s. Sorry.


#106

In the case of “1M” for sfdisk, that’s “one Megabyte”… not “L Megabyte”…

Based on your last post, you are right here after “ums 0 mmc 0”

SERIAL_CONSOLE_U_BOOT
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Net:   FEC0
Hit any key to stop autoboot:  0
=> ums 0 mmc 0

So go to here, and “copy n paste” the commands directly, don’t “try” to type them yourself…

https://www.digikey.com/eewiki/display/linuxonarm/PICO-PI-IMX7#PICO-PI-IMX7-Bootloader:imx_usb_loader

Regards,


#107

Sir,

This is in u-boot: ums 0 mmc 0.

This is my print out on the dev. desktop after the first command in the last link you gave when in /u-boot and typing: sudo ~/imx_usb_loader/imx_usb SPL

sudo ~/imx_usb_loader/imx_usb SPL
config file </home/torx/imx_usb_loader//imx_usb.conf>
vid=0x066f pid=0x3780 file_name=mx23_usb_work.conf
vid=0x15a2 pid=0x004f file_name=mx28_usb_work.conf
vid=0x15a2 pid=0x0052 file_name=mx50_usb_work.conf
vid=0x15a2 pid=0x0054 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0061 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0063 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0071 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x007d file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0080 file_name=mx6ull_usb_work.conf
vid=0x1fc9 pid=0x0128 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0076 file_name=mx7_usb_work.conf
vid=0x1fc9 pid=0x0126 file_name=mx7ulp_usb_work.conf
vid=0x15a2 pid=0x0041 file_name=mx51_usb_work.conf
vid=0x15a2 pid=0x004e file_name=mx53_usb_work.conf
vid=0x15a2 pid=0x006a file_name=vybrid_usb_work.conf
vid=0x066f pid=0x37ff file_name=linux_gadget.conf
vid=0x1b67 pid=0x4fff file_name=mx6_usb_sdp_spl.conf
vid=0x0525 pid=0xb4a4 file_name=mx6_usb_sdp_spl.conf
vid=0x1fc9 pid=0x012b file_name=mx8mq_usb_work.conf
no matching USB device found

It has always been this way when I try this route. Oh and sir, I see the config file line, line two, states // instead of single /. Does this matter.

Seth