Try reducing your serial speed and program again


#1

When attempting to load firmware, I am getting the error “Fatal error occurred while programming the ESP32, try reducing your serial speed and program again”. The serial speed is at the lowest setting, and I have tried all other speeds. The agent is currently running in my task bar, I only have 2 options for COM ports, and I have attempted both. Anyone have any ideas?


#2

Chad take a look here. there is a note about the Serial Port Speed.


#3

This does not look to be the same issue. He is not getting an error at all, and he is using ble. I am just downloading a code that blinks the LED on the board.


#4

Do you have these installed?

Full speed should work, just make sure you don’t have another program trying to talk to the unit…

Regards,


#5

This issued was resolved, however, it can not be done without some assistance as far as I was able to find.

The issue: Drivers were not correctly installed.

I am not completely sure how or why this happened, because others within my department were able to plug in the device, and the drivers were installed automatically, without issue.

The Solution: I filed a ticket with the IT department.

With the device plugged in, IT took control of my computer and uninstalled whatever corrupt driver was installed. We then proceeded to manually install the drivers. The driver download links are posted in the Github post from Rob, otherwise, they can be found here - https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers.

When it asks you to select the location of the driver you need to install, be sure to select the UNZIPPED CP210x_Windows_Drivers folder. DO NOT select any of the sub-folders, as this resulted in an error and the drivers were not recognized.

Once the driver is installed, everything worked as it should.