Flir Lepton 3 with Beaglebone black


#1

This is an area to ask questions that you have on our EEWiki post FLIR Lepton on BeagleBone Black and Green. You will also find summaries, links, and videos associated with the EEWiki. Feel free to post any questions as a reply and our Engineers and Techs will work with the Authors to get you the information you need.

Hi,

I hope I have created this topic in the correct and related field.

I have bought a Flir Lepton 3 thermal camera from Digi-key 2 months age. I followed the instructions on connecting the flir lepton to Beagle bone black on the “FLIR Lepton on BeagleBone Black and Green” topic. When I run the demo code I just get a red square. I have no idea what causes this problem.
Any comment, help and advice would be great for me.

Thank you in advance,
Ghazal


#2

Hi @GhazalM ,

I’ve been working on an internal project related to that wiki page:

https://eewiki.net/display/linuxonarm/FLIR+Lepton+on+BeagleBone+Black+and+Green

I’m also seeing the “red” square, so far I’ve tried back-porting to v4.1.x and an older git checkout of the FLIR project. Sadly still haven’t narrowed down what exactly changed that broke things…

Regards,


#3

Thank you so much for your reply @RobertCNelson.

So by back-porting to v4.1.x you get the FLIR working?

Thanks,
Ghazal


#4

@GhazalM success! With my first gen FLIR (80x60) I’ll update the wiki with what needs to be done. It’s either gcc or qt in Debian Stretch that breaks the build… You’ll need to use Debian Jessie, I just used this image:

https://rcn-ee.net/rootfs/bb.org/testing/2018-06-01/iot/bone-debian-8.10-iot-armhf-2018-06-01-4gb.img.xz

But i’ll update the wiki with the console variaent…

FLIR1

Regards,


#5

Wow! Great news @RobertCNelson!
I will check with this Debian image to see if I can get any image. Do you think I can get the same result with Lepton 3 too?
Thank you so much for your help.

Ghazal


#6

@GhazalM i’m not 100% sure, but I am pulling a FLIR 3 for validation, I’m not sure when it’ll make it up to my desk for testing.

Regards,


#7

OK @RobertCNelson. Thank you so much.
I am looking forward to hearing from you whenever you got the Flir 3 working.
Again, Thanks for your help.

Best regards,
Ghazal


#8

@GhazalM okay the wiki is re-updated, everything works again with the original Lepton sensors…

Sadly, after reading:

and

It looks like the Flir 3 isn’t fully supported yet by the “LeptonModule” project.

Regards,


#9

Thanks for your reply @RobertCNelson.

Yeah, you are right. I try to change the codes according to the FLIR 3 specs.
Please let me know if you have any idea or comments on it.

Thank you so much,
Ghazal


#10

@GhazalM there was a project over this last winter:

BeagleBone Blue + Lepton 3 sensor:

Here is the software repo:

Regards,