Shell access to the beaglebone black


First of all, many thanks for writing and maintaining the following topic debian-getting-started-with-the-beaglebone-black

I followed the previous tutorial to generate my own minimalist debian image up to the HDMI part where I was a bit confused.

To enable a the hdmi, I need to install a windows manager. However, I would require an access to the terminal on the beaglebone black after booting on the image that I uploaded to an SD Card, right ?

For this purpose, I saw 3 possibilities:

  • connect through an external USB to serial converter that I would connect to the UART port of the BBB => unfortunately I don’t have one right now
  • connect through the Mini-USB and use ssh debian@ => does not seems to work as have a connection timeout message
  • connect through Ethernet and use ssh debian@ => leads to the same error for either direct connection to my computer or to the router

After looking at the topic bbb-usb-gadget-questions, it appears that I need to do some manipulation from the beaglebone black to get that enabled.

Well, I was wondering if there is a way to bypass the external USB to serial converter since I don’t have one.

Is there any other way to get a shell access to the beaglebone black ?

Is it possible to install packages directly on the debian image we created on the sd card ?

Best regards,

That is incorrect, just plug in an HDMI monitor and plug in a usb keyboard. Console Terminal is always enabled… is only for usb, check with your router for the actual IP address of the Ethernet port…

Or once you plug in your HDMI monitor and USB keyboard type:

sudo ifconfig -a eth0

And you’ll see the board ip address.


Thanks for your reply Robert,

When I try to boot on the sd card, I have the four led that turn on and a I get a black screen on the monitor. That probably means that the sd card I prepared is not bootable
I will try to boot on an image found there - latest-images first.
Afterwards, I will check what could have gone wrong when I followed: Debian: Getting Started with the BeagleBone Black

4 solid led’s on bootup, mean u-boot tried to do something, but got stuck… Best thing to do is grab a usb-serial adapter and plug it into j1 and see what’s up…

You could also force the microSD to boot via:

  • Insert microSD
  • Hold Boot button
  • insert power
  • wait for led
  • lift Boot button

which would indicated an old version of u-boot in the eMMC…


Quick update: I managed to boot on a SD card containing an image from the beaglebone website (using the boot force method you gave)

I did not flash the MMC since I have my beaglebone black which is about 7 years old (2016) so when you mention an old version of u-boot, I think you are totally right.

I don’t have an usb-serial adapter for the moment but I should be able to get one in a few.

This is exactly what I have done to get the 4 solid led’s with my “custom debian” built using Debian: Getting Started with the BeagleBone Black.

What is the difference I should see with an updated version of u-boot ? Do we boot on the SD card without pushing on the boot button ?

Best regards,

Correct, with a newer version of u-boot on the eMMC it’ll better understand a more generic boot setup…

Back in 2016 lots of things was hard-coded…



After creating a new SD card to boot on (by following instructions on Debian: Getting Started with the BeagleBone Black). I plugged a monitor, a keyboard and a usb to serial converter and it just worked fine. I could access the terminal from the usb -serial converter and/or through the monitor and a keyboard plugged in the usb to the beaglebone black.

The next step is to get a gui.Please let me know if I should open a new topic for that.

Basically I did the following:
sudo apt update
sudo apt upgrade
sudo tasksel
then I followed the instructions to install GNOME
after the installation I performed a reboot and the beaglebone black seems to freeze after some initialization.

Through the usb serial converter I managed to catch the following:

[ OK ] Finished Permit User Sessions.
Starting GNOME Display Manager…
Starting Hold until boot process finishes up…
[ 37.665057] kauditd_printk_skb: 10 callbacks suppressed
[ 37.665078] audit: type=1400 audit(1677794436.732:22): apparmor=“DENIED” operation=“capable” profile=“/usr/sbin/cupsd” pid=346 comm=“cupsd” capability=12 capname=“net_admin”
[ OK ] Started CUPS Scheduler.
[ OK ] Started Make remote CUPS printers available locally.
[ OK ] Started OpenBSD Secure Shell server.
[ OK ] Started GNOME Display Manager.
[ 39.445996] audit: type=1400 audit(1677794438.512:23): apparmor=“DENIED” operation=“capable” profile=“/usr/sbin/cups-browsed” pid=360 comm=“cups-browsed” capability=23 capname=“sys_nice”

Then the following message occurs couple of time:
[ 62.241759] davinci-mcasp 48038000.mcasp: stream has more channels (2) than are enabled in mcasp (0)
[ 62.271777] davinci-mcasp 48038000.mcasp: ASoC: error at snd_soc_dai_hw_params on 48038000.mcasp: -22
[ 62.320563] davinci-mcasp.0-i2s-hifi: ASoC: soc_pcm_hw_params() failed (-22)

And finally the Beaglebone seems to freeze and I am unable to do anything from the monitor/keyboard or through the usb/serial converter.

Any clue how to solve that ?

GNOME takes a ton of resources…

switching to fbdev driver might fix the lockup, but it’ll still be too slow to be usable, documented here: Debian: Getting Started with the BeagleBone Black

Section "Monitor"
        Identifier      "Builtin Default Monitor"
Section "Device"
        Identifier      "Builtin Default fbdev Device 0"
        Driver          "fbdev"
Section "Screen"
        Identifier      "Builtin Default fbdev Screen 0"
        Device          "Builtin Default fbdev Device 0"
        Monitor         "Builtin Default Monitor"
Section "ServerLayout"
        Identifier      "Builtin Default Layout"
        Screen          "Builtin Default fbdev Screen 0"

If you want a usable desktop, our Bullesye repo has a meta package for: if you just need xorg for a quick application, use openbox…


Thank Robert for your replies

Thanks to your directions and the following topic Help needed to use drivers of Wand-board dual in Ubuntu minimal root file-system
I ran the following and it went just fine

Finally I ran the following:

chmod +x
sudo /bin/bash ./

I shutdown the Beaglebone Black, I removed the sd card and I observed a u-boot error through the usb-serial converter:

U-Boot SPL 2022.04-00037-ge0d31da5 (Feb 22 2023 - 14:02:01 -0800)
Trying to boot from MMC2
mmc_load_image_raw_sector: mmc block read error
spl_register_fat_device: fat register err - -1
spl_load_image_fat: error reading image u-boot.img, err - -1
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

I am not too sure what went wrong for u-boot. I tried to flash the emmc twice but ended up with the same result. Could you please help me out with this issue ?

I think this is fixed now, the size of MLO/u-boot-dtb.img has gotten bigger so i had to adjust the dd parameters…


Sorry for the delay. Your fix enabled me to write the eMMC of my BeagleBone Black.

Thank you very much Robert.