BBG no comms


Latest os image. I have been working with the Beagle Bone for a long time, always in the past was able to connect. This unit will not connect.

Hi @farside are you able to plug in a USB-serial adapter into J1?

If so can you share what it’s doing…

What image did you flash to your microSD? DId you use or something else?


I don’t have a usb-serial adaptor.
Image used: bone-debian-10.3-iot-armhf-2020-04-06-4gb.img
I used the linux command line dd. It always worked w/o issues in the past.


Oh, that makes it fun to debug…

Are any of the LED’s turning on? Or blinking? or…


Tell me about it.

The heartbeat goes, the other led’s light up for boot.

So it is running something…

The BeagleBone Green Wireless get’s power from the micro USB slot, and enables usb-cdc and usb-Ethernet thru that port…

Are you injecting power directly into the micro USB or can we plug that into another PC to login into the device? (assuming the other PC can provide proper power…)


I have a card that I put on the unit to bring all the i/o to multiple terminal strips. The last unit I had worked w/o out issues. This does not like the unit. I removed it and can now communicate with bb.
That is frustrating, but I can now configure it.
Thanks for the help!

Either the onboard eMMC is messing with your boot settings on your microSD or something else…

Or your working image was hard-coded to the mac/etc of the old unit…

If you have a microSD that should work, but doesn’t… I’d first erase the eMMC on the new device, and then try booting your old microSD…


I will give that a try.
Let you know.

What I found out, the board used to bring all i/o to terminals, was shorting with the usb ports on the usb green. It was created for the black. I had to extent it to prevent shorting. Works like a champ.

Thanks for all the help and suggestions!