Usb0 now showing beaglebone black

Hi I am installing image for beaglebone black and I installed following link

When I booted up, mine was debian@arm I didn’t install the beaglebone image to be able to use the kernel’s gcc.
Can anyone help me, connect usb0 or find the toolchain for img@beaglebone so I can write kernel module.

debian@arm:~$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::6a3:16ff:feac:24d7  prefixlen 64  scopeid 0x20<link>
        ether 04:a3:16:ac:24:d7  txqueuelen 1000  (Ethernet)
        RX packets 3295  bytes 218003 (212.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 656  bytes 50834 (49.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 12  bytes 1658 (1.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12  bytes 1658 (1.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
debian@arm:~$ ls /dev/usb0
ls: cannot access '/dev/usb0': No such file or directory

My gcc is


Hi @buihien29112002 ,

This is completely expected… USB0 configuration is not a hard set feature, it’s something you as the end users must enable in user-space.

Our Current Production line images: Topics tagged latest-images (Debian 11.x Bullseye)

Use systemd and systemd-network to make this very seamless.

You’ll need our bb-usb-gadgets project:

First make sure systemd-network is enabled and utilized, then install:

sudo apt update
sudo apt install bb-usb-gadgets

USB0/USB1 ip configuration is setup in: (default is used by

  • /etc/systemd/network/
  • /etc/systemd/network/

Default libcomposite configuration: (default is used by

and enable it:

sudo systemctl enable --now bb-usb-gadgets.service

and now reboot and bb-usb-gadget should load fine

sudo systemctl status bb-usb-gadget

For your other question. You’ve already built the kernel with a cross compiler, just add your external module into that build.


1 Like

Hello Robert
I cannot Install BB-USB-GADGETS
I downloaded the BB-USB-GADGETS source code but could not install it

What base image are you running?



Hello Robert,

I’ve tried to install, and it worked well when my “bbb” had a network connection. However, this time I’ve encountered an issue with the LAN port of my “bbb,” which is damaged and doesn’t receive any network connection when plugged in. As a result, my “bbb” doesn’t have network access, and I’m unable to install “usb0” and “usb1” using the ‘sudo install’ command. Is there an alternative way to install ‘bb-usb-gadgets’ and configure the network?


In this case, just grab one of the iot images, as this has usb0/usb1 pre-configured… Topics tagged latest-images


Yeah, I need to build the image again to have the toolchain, kernel, and u-boot for writing drivers and making custom modifications as per my requirements.

You’re welcome for the response!