Stm32mp157a-dk1 - unrecognized filesystem

Good day. I have a stm32mp157a-dk1. I wanted to install linux on the board according to the instructions
When u-boot is loaded from a microSD card, a message appears: “unrecognized filrsystem” and the download stops. Help to understand please.

@alexander, without seeing your exact u-boot error message, i’m betting you missed this step:

Set legacy BIOS partition

sudo sgdisk -A 4:set:2 ${DISK}



I ask you to forgive me - after a thorough reinstallation, the problem is gone. Another came :slight_smile: I can not lift the network on the wired interface. It links, but the ping does not go. Help me please. I am new in these matters. Thank you in advance.

Hi @alexander, in 5.2.x right now both USB and Ethernet seem to have issues, 5.3.0-rc1 should hit Sunday afternoon, i’m hoping more of the STM32MP patches have made it to mainline…


1 Like

Thank you for your work. I look forward to the patch. Tell me please, and the instructions for installing the patched distribution will be changed? Thank you very much in advance!

Good day. Sorry for the intrusiveness, and what changes in the instructions, if you try another kernel, which is without bugs for USB and Ethernet? Probably a lot … and script and other things. I would like to try another build before the 5.3.0-rc1 release … Thank you in advance.

Good afternoon. I tried to do everything according to the instructions, but with the kernel 4.19.50-armv7-lpae-x35. The system is not loaded. Writes the following:
U-Boot SPL 2019.07-rc4-dirty (Jul 22 2019 - 09:53:17 +0300)
Model: STMicroelectronics STM32MP157A-DK1 Discovery Board
RAM: DDR3-1066 / 888 bin G 1x4Gb 533MHz v1.44
Trying to boot from MMC1

U-Boot 2019.07-rc4-dirty (Jul 22 2019 - 09:53:17 +0300)

Model: STMicroelectronics STM32MP157A-DK1 Discovery Board
Board: stm32mp1 in basic mode (st, stm32mp157a-dk1)
Board: MB1272 Var1 Rev.C-01
DRAM: 512 MiB

  • MPU: 650 MHz
  • MCU: 208.878 MHz
  • AXI: 266.500 MHz
  • PER: 24 MHz
  • DDR: 533 MHz
    MMC: STM32 SDMMC2: 0
    In: serial @ 40010000
    Out: serial @ 40010000
    Err: serial @ 40010000
    Net: Net Initialization Skipped
    No ethernet found.
    Hit any key to stop autoboot: 0
    Boot over mmc0!
    switch to partitions # 0, OK
    mmc0 is current device
    Scanning mmc 0: 4 …
    Found /boot/extlinux/extlinux.conf
    Retrieving file: /boot/extlinux/extlinux.conf
    286 bytes read in 2 ms (139.6 KiB / s)
    1: Linux 4.19.50-armv7-lpae-x35
    Retrieving file: /boot/vmlinuz-4.19.50-armv7-lpae-x35
    7639552 bytes read in 326 ms (22.3 MiB / s)
    append: console = ttySTM0,115200 root = / dev / mmcblk0p4 ro rootfstype = ext4 rootwait quiet
    Retrieving file: /boot/dtbs/4.19.50-armv7-lpae-x35/stm32mp157a-dk1.dtb
    Skipping Linux 4.19.50-armv7-lpae-x35 for failure retrieving fdt
    SCRIPT FAILED: continuing …

How to do everything right? That there were no problems with eth and usb and that everything was loaded …
thanks in advance.
I will add, so that others know in advance. The manual version, edited July 19, 2019, leads me to a constant reboot of the system. (The u-boot has been removed: “-rc4”
"cd u-boot /
git checkout v2019.07-rc4 -b tmp "

@alexander, networking now works with 5.3-rc2:

 uname -r ; cat /proc/device-tree/model ; sudo ifconfig -a ; ping -c3

STMicroelectronics STM32MP157C-DK2 Discovery Board
eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::280:e1ff:fe42:590a  prefixlen 64  scopeid 0x20<link>
        ether 00:80:e1:42:59:0a  txqueuelen 1000  (Ethernet)
        RX packets 137  bytes 12104 (11.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 91  bytes 10430 (10.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 44  base 0x8000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 189  bytes 16222 (15.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 189  bytes 16222 (15.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=44 time=477 ms
64 bytes from ( icmp_seq=2 ttl=44 time=832 ms
64 bytes from ( icmp_seq=3 ttl=44 time=858 ms

--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 11485ms
rtt min/avg/max/mdev = 477.105/722.464/858.219/173.824 ms

Note, with u-boot v2019.10-rc1, u-boot will now write to the disk on bootup, we need to disable metadata_csum as u-boot will corrupt the image… (there are patches on the u-boot list to fix this, but for right now…)


1 Like

Thanks a lot! | And for your time and work. And with usb, the problem is also solved in this version? Thank…
There would be more such people on earth …

I’ve some problem with my STM32MP157-DK2.
I started test with kernel version 5.2.0 : board boot up correctly, LCD display works fine, ethernet and USB don’t work.
After this I updated kernel to 5.3.0-rc2 : boot up is correct, ethernet and USB works fine but LCD display stop working.

I tried at this point an update of uboot to 2019.10-rc1 : I get this:

Net:   eth0: ethernet@5800a000
Hit any key to stop autoboot:  0
Boot over mmc0!
Saving Environment to EXT4... Journal Scan Completed
Recovery required
Journal Recovery Completed
Unsupported feature metadata_csum found, not writing.

** Unable to write "/uboot.env" from mmc0:4 **
Failed (1)
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:4...
Found /boot/extlinux/extlinux.conf
Retrieving file: /boot/extlinux/extlinux.conf
290 bytes read in 20 ms (13.7 KiB/s)
1:      Linux 5.3.0-rc2-armv7-lpae-x1
Retrieving file: /boot/vmlinuz-5.3.0-rc2-armv7-lpae-x1
10625536 bytes read in 469 ms (21.6 MiB/s)
append: console=ttySTM0,115200 root=/dev/mmcblk0p4 ro rootfstype=ext4 rootwait quiet
Retrieving file: /boot/dtbs/5.3.0-rc2-armv7-lpae-x1/stm32mp157c-dk2.dtb
53274 bytes read in 49 ms (1 MiB/s)
## Flattened Device Tree blob at c4000000
   Booting using the fdt blob at 0xc4000000
   Using Device Tree in place at c4000000, end c4010019

Starting kernel ...

[    0.007362] /cpus/cpu@0 missing clock-frequency property
[    0.007398] /cpus/cpu@1 missing clock-frequency property
[    2.575625] EXT4-fs (mmcblk0p4): VFS: Found ext4 filesystem with invalid superblock checksum.  Run e2fsck?
[    2.584267] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,4)
[    2.592365] CPU: 0 PID: 1 Comm: swapper/0 Tainted: G        W         5.3.0-rc2-armv7-lpae-x1 #1
[    2.601191] Hardware name: STM32 (Device Tree Support)
[    2.606383] [<c022b0d5>] (unwind_backtrace) from [<c0226505>] (show_stack+0x11/0x14)
[    2.614158] [<c0226505>] (show_stack) from [<c0bc6685>] (dump_stack+0x5d/0x6c)
[    2.621420] [<c0bc6685>] (dump_stack) from [<c024adad>] (panic+0xc5/0x250)
[    2.628331] [<c024adad>] (panic) from [<c120136d>] (mount_block_root+0x14b/0x1d8)
[    2.635851] [<c120136d>] (mount_block_root) from [<c12014e1>] (mount_root+0xe7/0xf8)
[    2.643637] [<c12014e1>] (mount_root) from [<c12015d7>] (prepare_namespace+0xe5/0x126)
[    2.651599] [<c12015d7>] (prepare_namespace) from [<c1201055>] (kernel_init_freeable+0x2c9/0x2dc)
[    2.660524] [<c1201055>] (kernel_init_freeable) from [<c0bd6ced>] (kernel_init+0xd/0xd0)
[    2.668659] [<c0bd6ced>] (kernel_init) from [<c02011e9>] (ret_from_fork+0x11/0x28)
[    2.676262] Exception stack(0xdb141fb0 to 0xdb141ff8)
[    2.681339] 1fa0:                                     00000000 00000000 00000000 00000000
[    2.689564] 1fc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[    2.697785] 1fe0: 00000000 00000000 00000000 00000000 00000013 00000000
[    2.704441] CPU1: stopping
[    2.707146] CPU: 1 PID: 0 Comm: swapper/1 Tainted: G        W         5.3.0-rc2-armv7-lpae-x1 #1
[    2.715973] Hardware name: STM32 (Device Tree Support)
[    2.721150] [<c022b0d5>] (unwind_backtrace) from [<c0226505>] (show_stack+0x11/0x14)
[    2.728932] [<c0226505>] (show_stack) from [<c0bc6685>] (dump_stack+0x5d/0x6c)
[    2.736194] [<c0bc6685>] (dump_stack) from [<c0229799>] (handle_IPI+0x2f9/0x31c)
[    2.743631] [<c0229799>] (handle_IPI) from [<c06c9f99>] (gic_handle_irq+0x69/0x6c)
[    2.751240] [<c06c9f99>] (gic_handle_irq) from [<c0201b93>] (__irq_svc+0x53/0x94)
[    2.758754] Exception stack(0xdb15ff60 to 0xdb15ffa8)
[    2.763836] ff60: 00000000 00001bb8 db9adbf0 c0234341 ffffe000 c1405df8 c1405e3c 00000002
[    2.772059] ff80: 00000000 c1304428 c0e504c8 00000000 00000000 db15ffb0 c0223eeb c0223eec
[    2.780277] ffa0: 40000033 ffffffff
[    2.783785] [<c0201b93>] (__irq_svc) from [<c0223eec>] (arch_cpu_idle+0x28/0x2c)
[    2.791224] [<c0223eec>] (arch_cpu_idle) from [<c027009d>] (do_idle+0x16d/0x1e0)
[    2.798660] [<c027009d>] (do_idle) from [<c027032d>] (cpu_startup_entry+0x19/0x1c)
[    2.806270] [<c027032d>] (cpu_startup_entry) from [<c0202631>] (__enable_mmu+0x1/0x10)
[    2.814237] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,4) ]---

Robert writes this note about u-boot :

Note, with u-boot v2019.10-rc1, u-boot will now write to the disk on bootup, we need to disable
metadata_csum as u-boot will corrupt the image… (there are patches on the u-boot list to fix this, but >for right now…)

But this is not clear for me. How I can get system working again ??
Someone could help me ?

Thank you.

@mutty, basically start from scratch, when you get to the stage where you create the ext4 partition, make sure you have the ^metadata_csum flag disabled as shown on the wiki.

Essentially, u-boot is corrupting the ext4 partition, as it’s not able to handle metadata_csum in v2019.10-rc1…



I miss this update in your instruction, as you correctly indicated:

for : DISK=/dev/sdX
sudo mkfs.ext4 -L rootfs -O ^metadata_csum,^64bit ${DISK}4

The strange thing is that I tried a fresh installation but boot process hangs just in the beginning now:

U-Boot SPL 2019.10-rc1 (Aug 01 2019 - 07:09:36 -0400)
Model: STMicroelectronics STM32MP157C-DK2 Discovery Board
RAM: DDR3-1066/888 bin G 1x4Gb 533MHz v1.44
WDT: Not found!
Trying to boot from MMC1

(hangs here… )

It has no sense: probably I’ve done something wrong. I’ve to retry from the beginning.

Good day. Please tell me, how are your experiments going? Did you get the system installed?
Unfortunately, I can’t check it myself. I don’t have the equipment now.
Sincerely, Alexander.

Dear Alexander

Now system partially works fine. I recompiled uboot changing compiler version ( the same as indicated in the instruction, before I was using a newer one ).
After this boot is completed perfectly.
Now I have, LCD display, ethernet, serial console that are perfect. USB seems that is not yet working.

Clear, thank you very much for the information. When I finish my installation, I will also describe the results of the work to you, if you are interested. Thanks again, with respect, Alexander.

Dear Alexander,

please keep me updated about result of your test. This would be very useful for me.

Thank you.

Fine. We will be friends :slight_smile: I will do so. Equipment will be available soon - in a few days. Good luck to you.