A1324LUA-T issues with output

Hello everyone. I recently bought the A1324LUA-T linear Hall effect sensor, and am having some issues with it. I have it hooked up like in the “standard application circuit” shown in the datasheet, with the output going to my Raspberry Pi Pico, which is just reading the data through the analog to digital converter and printing it out to my pc. Trying it out though, the values it’s reading seem more digital than analog. When no magnet is near, it reads ~1.05V, and when a magnet is very, very close (<0.75cm) it reads ~0.75V, shown in the following image.

I’ve isolated the issue to either the sensors, and have tried all 3 of the sensor that I own to the same results. The magnets I am using are very powerful by most standards, being Neodymium-Iron-Boron. I also jerry rigged a snap circuits variable resistor to the ADC and all the values from that seemed correct.

I would really like to come to a solution, since I don’t think I can ensure success for what I am using these for in this state.

If there’s any troubleshooting steps I should take or more information I should provide to solve this please let me know!

Many thanks!

Welcome to the Technical Forum. The sentence in the data shet states that the sensor IC will provide a voltage outout that is directly proprtional to the applied magnetic field. Maybe the magnet you have is to strong and the sensor is not reading correctly.

Thanks for the welcome!

I tried my current setup with some fridge magnets, with no change. Looking through the datasheet it also says that the quiescent voltage output should be 2.5V, but I am getting the aforementioned 1.05V output with no magnetic signal.

Hi 28add11,

First, could you double-check that the pins are connected correctly, i.e. the middle pin is the ground and pin 3 is the output?
Then, disconnect the pin 3 from the ADC input and measure the voltage at the pin 3 (while pin 1 is receiving supply voltage - measure that too - and pin 2 is grounded.) Do you get that 2.5V?

heke, AsamaLab

Make sure you are using a 5V +/-10% power supply capable of providing at least 10mA for the sensor because it’s a very power hungry sensor according to the data sheet.

I don’t see that there is a 4.5V~5V output on the Pi Pico, what are you using to power the sensor?

Thank you so much, this fixed my issue! Turns out I misread the datasheet… Hopefully a mistake I won’t make again! Many thanks.

I don’t see that there is a 4.5V~5V output on the Pi Pico, what are you using to power the sensor?

Since I’m running the Pi Pico off a phone charger, since it has a micro USB input, the VBUS pin is at 5V, so I’m just using that.

Thanks all, I’m glad I could find a solution!

1 Like