Beagle Bone Black GPIO with Device Tree Overlay


#1

I am running Debian Stretch with the 4.14.40-ti-r50 kernel and a U-Boot version of [U-Boot 2018.03-00002-gac9cce7c6a]

The problem that I am running into is that I am unable to control my GPIO’s after updating my Device Tree Overlay. I updated the DTO as per page 7 of this pdf.

The Skywire BeagleBone Black Cape is able to connect to the internet as intended, I just cannot control any of the other GPIO’s now. I have tried to manually controll the GPIO’s through terminal under the /sys/classes/gpio settings and it only displays 2 gpios that are not even on the BBB pin out diagram, and when I try to export the correct GPIO’s into this list, I am able to change the values but it will not send the signal over the GPIO. I even check to see if the GPIO’s are MUX’d, but non of them show as available. I am thinking it was when I updated the device tree overlay as per the user manual for the cape that caused this issue. I am needing the GPIOs to connect to sensors and LEDs but without control of the GPIOs, my program won’t work.

If you need any other log files, please let me know.


#2

Hi Travis,

I’m currently away from my Skywire cape.

But yes, any pins not used by the cape should be free to export thru /sys/class/gpio.

Which pins are you trying to export, remember hdmi-audio is enabled by default, so you might need to disable some of the on-board devices:

https://elinux.org/Beagleboard:BeagleBoneBlack_Debian#U-Boot_Disable_on-board_devices

Regards,


#3

Good Afternoon Robert,

Thank you for responding, but thankfully I was able to fix my issue earlier today by changing the Kernel and Uboot versions. My problem is no longer existent.

I guess I should mark this topic as closed or something, I just am not exactly sure how.

But thank you again for taking the time to respond.