Bluetooth device Not listed

Hi Robert,

I found bluetooth device is not started in our BBB board. I checked, bluetooth package is installed.
sudo hcitool dev : shows empty device list
/var/lib/settings : Bluetooth is enabled
sudo hciconfig : shows empty list
sudo rfkill list: only shows 0: phy0: Wireless LAN
dmesg :
[ 1061.754757] Bluetooth: Core ver 2.22
[ 1061.755010] Bluetooth: HCI device and connection manager initialized
[ 1061.755041] Bluetooth: HCI socket layer initialized
[ 1061.755056] Bluetooth: L2CAP socket layer initialized
[ 1061.755123] Bluetooth: SCO socket layer initialized

no hciuart.service was found under /lib , /etc

Any suggestions?

Best Regards,

David

Hi Robert,

After I run the command:
hciattach /dev/ttyO3 any 115200 noflow

hciattach /dev/ttyO3 any 115200 noflow

sudo hciconfig -a
hci0: Type: Primary Bus: UART
BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
DOWN
RX bytes:0 acl:0 sco:0 events:0 errors:0
TX bytes:36 acl:0 sco:0 commands:9 errors:0
Features: 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
Packet type: DM1 DH1 HV1
Link policy:
Link mode: SLAVE ACCEPT

BUT: the command:
sudo hciconfig hci0 up
Can’t init device hci0: Connection timed out (110)

It seems there is hardware issue. The gpio28 pin problem?

Thank You,
David

Hi Robert,

I noticed that the BD Address is all 0s. Is that assigned from EEPROM or is it assigned when the device is initailized?

Thank You,
David

You don’t need to use hciattach anymore, this takes care of that:

&uart3 {
	pinctrl-names = "default";
	pinctrl-0 = <&uart3_pins &bt_pins>;
	status = "okay";

	bluetooth {
		compatible = "ti,wl1835-st";
		enable-gpios = <&gpio1 28 GPIO_ACTIVE_HIGH>;
	};
};

Can you share your bluetooth connections?

rxd, txd, cts, rts, and bt_en???

Regards,

Hi Robert,

I tried another board, and bluetooth is loaded and started by itself. So, the problem is on the hardware.

Thank you for your help,
David