Cant open display : xrandr --output HDMI-0

Hello ,
I am on ubuntu 20.04 and kernel 4.7.9-bone3 on Beagleboneblack

below command gives

Cant open display.

xrandr --output HDMI-0 --mode 1024x768 --rate 60

I have connected HDMI cable and running it using wireless keywboard. (HDMI is up)


Hi @sr007, are you typing in the commands over SSH/Serial, or with your keyboard with the display?

xrandr -display :0.0 --output HDMI-0 --mode 1024x768 --rate 60

If so you need to add the “-display :0.0” option…


Hello @RobertCNelson,
with my keyboard with the display
again : Can’t open display :0.0

before that :

sudo apt update

sudo apt install read-edid xserver-xorg-video-fbdev x11-xserver-utils


Section "Monitor"

Identifier "Builtin Default Monitor"


Section "Device"

Identifier "Builtin Default fbdev Device 0"

Driver "fbdev"


Section "Screen"

Identifier "Builtin Default fbdev Screen 0"

Device "Builtin Default fbdev Device 0"

Monitor "Builtin Default Monitor"


Section "ServerLayout"

Identifier "Builtin Default Layout"

Screen "Builtin Default fbdev Screen 0"


Thanks and Regards,

Hi @sr007, looking at your picture you are just logged into the DRM console. xrandr needs Xorg to be up and running, so you’ll need to start your window manager.

This will take up a bunch of memory space, in your application do you need a full X11 based window manager?

If we just need to resize the DRM console, it would be best to pass the video parameter from /boot/uEnv.txt

Open /boot/uEnv.txt find the “un-commented” cmdline variable and add this to the end:



1 Like

Hello @RobertCNelson ,
I am on uSD (32GB), I can try this.I need to do basic functionalities from the GUI like editor,network configuration and some custom GUI tool running.
Do I need to install anything extra apart from what I did above?
I can try with


btw my uEnv.txt has just the kernel image name.( uname_r=4.7.9-bone3)

Thanks and Regards,

Start by installing openbox:

sudo apt install openbox slim xinit xserver-xorg-video-fbdev x11-xserver-utils git libpam-gnome-keyring

Then configure “slim” for auto login.

This will give you a very simple gui.


1 Like