DeskPi won't turn on or won't provide video output

I recently purchased DeskPi (114992373), but I could not make it work.
All the cables are connected nice and tight. It won’t come off easily. When I plug the power in, the power button turns red. Pushing it turns it blue and a red LED on RPi 4 turns on and a green one flashes for a while. However, I don’t get any video outputs.

I am using a micro SD card that has Rasberry Pi OS, that is working with this particular RPi 4 board.

I checked the FAQ that came with the product, and tried flipping the USB C cable, check and refasten the ribbon cables, and used different USB C cables and a power source. I check the other end of the cables (which are already installed), and these ends are fastened well too.

Any help is appreciated.


Welcome to the forum.

I need to preface this with the fact that I’ve never used a DeskPi Pro case or a Pi4.

The description seems to point toward the micro-HDMI to HDMI adapter cables in the DeskPi case not functioning with your monitor. FYI the Pi’s red LED indicates power on and the green LED indicates that uSD card is being accessed.

To verify this I’d do this test sequence:

  • Re-verify operation without the case using the Pi, uSD card, monitor and a seperate micro-HDMI to HDMI adapter cable.
  • Check operation with the DeskPi case’s other systems but still the external micro-HDMI to HDMI adapter cable.

If the system works OK in both of the tests then the problem must be the micro-HDMI to HDMI adapter cables in the DeskPi case.

You may find other helpful troubleshooting information from the DeskPi companies GitHub pages.
Main page:

Thank you, Paul, for your quick response!

I check the RPi 4 board + the same micro SD card without the DeskPi, and it works just fine. Since I have to take the whole thing apart, I installed deskpi (not required for just building, but just in case).

I plugged components part by part to see if I can locate the issue.

  1. GIPO adapter - OK (i.e., boot to the desktop)
  2. GIPO adapter connected to the board - OK
  3. Above plus SD card adapter with a micro SD card - OK
  4. Above plus HDMI (and all) board connected - fail to provide video output. (When I tried to connect to RPi via VNC, it says “Cannot currently show the desktop”.)
  5. Above minus the micro SD card - shows the start-up dialogue, looking for an SD card, then goes blank after 10 sec or so.
  6. Above (i.e., no micro SD card) plus an SSD on the DeskPi caddy - the start-up dialogue shows up, looking for an SD card, then goes blank. I believe it tries to load the OS from the SSD, white light blinking on the DeskPi board, but no video output. I waited for about 15 min, but no luck. The white light stopped blinking after 3-4 min. I cannot connect to the RPi via VNC.

This SSD is able to boot the same RPi 4 using a regular USB cable. (i.e., the installed RPi has been configured to be booted from the SSD on a USB port).

I tried it with two different monitors, and both did not work.