Failed to enable BBB wifi

#1

Hello,

I met this problem on Beagleboneblack wireless and error log as below.
Could you help provide instructions on how to debug such problems?
Thanks in advance.

root@arm:~# connmanctl
connmanctl> enable wifi
Error wifi: Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

connmanctl> scan wifi
Error /net/connman/technology/wifi: Method “Scan” with signature “” on interface “net.connman.Technology” doesn’t exist

connmanctl> services

connmanctl> agent on
Agent registered
connmanctl> quit
root@arm:~# uname -a
Linux arm 4.19.19-bone-rt-r21 #1 PREEMPT RT Mon Feb 11 15:17:49 CST 2019 armv7l GNU/Linux
root@arm:~# cat /etc/issue
Debian GNU/Linux 9 \n \l

default username:password is [debian:temppwd]
root@arm:~# cat /boot/uEnv.txt
uname_r=4.19.19-bone-rt-r21
optargs=quiet lpj=1990656
disable_uboot_overlay_video=1
disable_uboot_overlay_audio=1
disable_uboot_overlay_adc=1
uuid=cf9a32c1-ca83-4c8d-aec2-adc9d50334a9
root@arm:~#

#2

Hello Springzhang, could you please provide the part number for the exact Beaglebone black you are referring to?

#3

Sure. Can you tell me which cmd to fetch what you need?

#4

Is BBBWL-SC-562-ND the part you are referring to? https://www.digikey.com/short/ppch49

#5

@springzhang

Please run this command and share the output:

sudo /opt/scripts/tools/version.sh

Regards,

#6

root@arm:~# /opt/scripts/tools/version.sh
git:/opt/scripts/:[702a85c3ea80bf39c36f539e40dbd0e877b173dc]
eeprom:[A335BNLTBWA51905BBWG0309]
model:[TI_AM335x_BeagleBone_Black_Wireless]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.09-dirty]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[location: dd MBR]
kernel:[4.19.19-bone-rt-r21]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20190123.0-0rcnee0~stretch+20190123]
WARNING:pkg:[bb-wl18xx-firmware]:[NOT_INSTALLED]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20180825+dfsg-1rcnee1~stretch+20181217]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c netdev gpio pwm eqep bluetooth admin spi tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 quiet lpj=1990656 root=UUID=cf9a32c1-ca83-4c8d-aec2-adc9d50334a9 ro rootfstype=ext4 rootwait]
dmesg | grep pinctrl-single
[ 0.632873] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
root@arm:~#

Additionally, I attach the kernel config for your reference in case I missed some driver during build kernel.
config-4.19.19-bone-rt-r21.txt (125.3 KB)

B.R.

#7

I’ll test that kernel tomorrow…

This is an issue…

sudo apt update
sudo apt install --only-upgrade bb-wl18xx-firmware firmware-ti-connectivity

Regards,

#8

which kernel can support wireless BBB? what’s the root cause for that issue? I guess I missed something during build kernel.
B.R.

#9

Well let’s compare your config with what i offically shipped with: “4.19.19-bone-rt-r21”

git diff .config ~/Downloads/config-4.19.19-bone-rt-r21.txt > config.diff
-CONFIG_WLAN_VENDOR_TI=y
-CONFIG_WL1251=m
-CONFIG_WL1251_SPI=m
-CONFIG_WL1251_SDIO=m
-CONFIG_WL12XX=m
-CONFIG_WL18XX=m
-CONFIG_WLCORE=m
-CONFIG_WLCORE_SPI=m
-CONFIG_WLCORE_SDIO=m
-CONFIG_WILINK_PLATFORM_DATA=y

and

-CONFIG_WLAN=y

Yeap, you broke WiFi… Start again at the beginning and don’t go so crazy on disabling everything…

Regards,

#10

I just finish “sudo apt install --only-upgrade bb-wl18xx-firmware firmware-ti-connectivit”
root@arm:~# /opt/scripts/tools/version.sh
git:/opt/scripts/:[702a85c3ea80bf39c36f539e40dbd0e877b173dc]
eeprom:[A335BNLTBWA51905BBWG0309]
model:[TI_AM335x_BeagleBone_Black_Wireless]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.09-dirty]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[location: dd MBR]
kernel:[4.19.19-bone-rt-r21]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20190123.0-0rcnee0~stretch+20190123]
pkg:[bb-wl18xx-firmware]:[1.20190227.1-0rcnee0~stretch+20190227]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20180825+dfsg-1rcnee1~stretch+20181217]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c netdev gpio pwm eqep bluetooth admin spi tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 quiet lpj=1990656 root=UUID=cf9a32c1-ca83-4c8d-aec2-adc9d50334a9 ro rootfstype=ext4 rootwait]
dmesg | grep pinctrl-single
[ 0.632839] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper
root@arm:~# connmanctl
connmanctl> enable wifi
Error wifi: Method “SetProperty” with signature “sv” on interface “net.connman.Technology” doesn’t exist

connmanctl>

#11

Thanks so much. I will change to another image without kernel cutting.

#12
sudo apt update
sudo apt install linux-image-4.19.19-bone-rt-r21

Regards,

#13

Hello,
I change to another image and still failed.
config-4.14.79-ti-rt-r86.txt (130.3 KB)

root@arm:~#
root@arm:~# pwd
/root
root@arm:~# /opt/scripts/tools/version.sh
git:/opt/scripts/:[29878c8f9a13833ac69956ecc086c95b99726dde]
eeprom:[A335BNLTBWA51905BBWG0309]
model:[TI_AM335x_BeagleBone_Black_Wireless]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.09-dirty]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[location: dd MBR]
kernel:[4.14.79-ti-rt-r86]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20180727.0-0rcnee0~stretch+20180727]
pkg:[bb-wl18xx-firmware]:[1.20190227.1-0rcnee0~stretch+20190227]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
pkg:[librobotcontrol]:[1.0.4-git20190227.1-0rcnee0~stretch+20190327]
pkg:[firmware-ti-connectivity]:[20180825+dfsg-1rcnee1~stretch+20181217]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c netdev gpio pwm eqep bluetooth admin spi tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 quiet lpj=1990656 root=UUID=eefcaffa-1f67-46ee-8fe4-c3187c919829 ro rootfstype=ext4 rootwait]
dmesg | grep pinctrl-single
[ 1.168593] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
dmesg | grep gpio-of-helper
[ 1.170496] gpio-of-helper ocp:cape-universal: ready
END
root@arm:~# systemctl status bb-wl18xx-wlan0.service
● bb-wl18xx-wlan0.service - BB WL18xx wlan0 Service
Loaded: loaded (/lib/systemd/system/bb-wl18xx-wlan0.service; enabled; vendor
preset: enabled)
Active: activating (auto-restart) (Result: timeout) since Fri 2016-11-04 04:0
9:38 CST; 1s ago
Process: 17139 ExecStart=/usr/bin/bb-wl18xx-wlan0 (code=killed, signal=TERM)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/bb-wl18xx-wlan0.service

Nov 04 04:09:38 arm systemd[1]: bb-wl18xx-wlan0.service: Unit entered fa
iled state.
Nov 04 04:09:38 arm systemd[1]: bb-wl18xx-wlan0.service: Failed with res
ult ‘timeout’.
root@arm:~# /usr/bin/bb-wl18xx-wlan0
wlan_0_mac=[00:00:00:00:00:00], this forces internal wl18xx mac address…
/lib/firmware/ti-connectivity/wl1271-nvs.bin=[00:00:00:00:00:00]
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0
wl18xx:tether waiting for /sys/class/net/wlan0

#14

Here’s the diff to your custom config-4.14.79-ti-rt-r86.txt…

-CONFIG_WL1251=m
-CONFIG_WL1251_SPI=m
-CONFIG_WL1251_SDIO=m
-CONFIG_WL12XX=m
-CONFIG_WL18XX=m
-CONFIG_WLCORE=m
-CONFIG_WLCORE_SPI=m
-CONFIG_WLCORE_SDIO=m

So YOU broke WiFI again. Feel free to use the “default” kernel configuration, which support these Single Board Computers by default…

sudo apt update
sudo apt install linux-image-4.14.79-ti-rt-r86

Regards,

#15

Thanks much.
I just update the image and wifi works well.
How about the bluetooth failure? Did I miss something else?

root@arm:~# hciconfig -a
hci0: Type: Primary Bus: UART
BD Address: 18:62:E4:07:A5:4E ACL MTU: 1021:6 SCO MTU: 180:4
DOWN
RX bytes:3065 acl:0 sco:0 events:378 errors:0
TX bytes:73898 acl:0 sco:0 commands:379 errors:0
Features: 0xff 0xfe 0x2d 0xfe 0xdb 0xff 0x7b 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF
Link mode: SLAVE ACCEPT
root@arm:~# sdptool browse local
Failed to connect to SDP server on FF:FF:FF:00:00:00: No such file or directory
root@arm:~# hcitool scan
Device is not available: No such device
root@arm:~# hciconfig hci0 iscan
Can’t set scan mode on hci0: Network is down (100)

root@arm:~# dmesg | grep tooth
[ 13.639249] Bluetooth: Core ver 2.22
[ 13.639384] Bluetooth: HCI device and connection manager initialized
[ 13.639407] Bluetooth: HCI socket layer initialized
[ 13.639417] Bluetooth: L2CAP socket layer initialized
[ 13.639456] Bluetooth: SCO socket layer initialized
[ 13.797317] Bluetooth: HCI UART driver ver 2.3
[ 13.797331] Bluetooth: HCI UART protocol H4 registered
[ 13.797417] Bluetooth: HCI UART protocol LL registered
[ 13.797423] Bluetooth: HCI UART protocol ATH3K registered
[ 13.797476] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 13.913823] Bluetooth: hci0: change remote baud rate command in firmware
[ 17.283909] Bluetooth: hci0: command 0xff05 tx timeout
[ 25.315898] Bluetooth: hci0: send command failed
[ 25.320606] Bluetooth: hci0: download firmware failed, retrying…
[ 25.485396] Bluetooth: hci0: change remote baud rate command in firmware

root@arm:~# systemctl status bb-wl18xx-bluetooth.service
● bb-wl18xx-bluetooth.service - BB WL18xx Bluetooth Service
Loaded: loaded (/lib/systemd/system/bb-wl18xx-bluetooth.service; enabled; vendor preset: en
abled)
Active: inactive (dead) since Mon 2019-02-11 00:00:09 CST; 3min 55s ago
Process: 607 ExecStart=/usr/bin/bb-wl18xx-bluetooth (code=exited, status=0/SUCCESS)

Feb 11 00:00:06 arm systemd[1]: Starting BB WL18xx Bluetooth Service…
Feb 11 00:00:09 arm bb-wl18xx-bluetooth[607]: Can’t open serial port: No such file or director
y
Feb 11 00:00:09 arm bb-wl18xx-bluetooth[607]: Can’t initialize device: No such file or directo
ry
Feb 11 00:00:09 arm systemd[1]: Started BB WL18xx Bluetooth Service.

root@arm:~# /opt/scripts/tools/version.sh
git:/opt/scripts/:[702a85c3ea80bf39c36f539e40dbd0e877b173dc]
eeprom:[A335BNLTBWA51905BBWG0309]
model:[TI_AM335x_BeagleBone_Black_Wireless]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.09-dirty]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[location: dd MBR]
kernel:[4.19.19-bone-rt-r21]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20190123.0-0rcnee0~stretch+20190123]
pkg:[bb-wl18xx-firmware]:[1.20190227.1-0rcnee0~stretch+20190227]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20180825+dfsg-1rcnee1~stretch+20181217]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c netdev gpio pwm eqep bluetooth admin spi tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 quiet lpj=1990656 root=UUID=cf9a32c1-ca83-4c8d-aec2-adc9d50334a9 ro rootfstype=ext4 rootwait]
dmesg | grep pinctrl-single
[ 0.596195] pinctrl-single 44e10800.pinmux: 142 pins, size 568
dmesg | grep gpio-of-helper

root@arm:~# systemd-analyze blame
13.932s bb-wl18xx-wlan0.service
7.438s dev-mmcblk0p1.device
7.135s generic-board-startup.service
3.135s bb-wl18xx-bluetooth.service
1.192s ssh.service
1.190s systemd-udev-trigger.service
729ms systemd-journald.service
591ms connman.service
588ms systemd-rfkill.service
492ms systemd-remount-fs.service
398ms wpa_supplicant.service
316ms hostapd.service
308ms systemd-tmpfiles-setup-dev.service
300ms systemd-udevd.service
273ms systemd-sysctl.service
260ms sys-kernel-config.mount
257ms systemd-logind.service
249ms dev-mqueue.mount
248ms user@0.service
244ms systemd-user-sessions.service
240ms sys-kernel-debug.mount
214ms systemd-update-utmp.service
200ms systemd-modules-load.service
196ms kmod-static-nodes.service
192ms systemd-journal-flush.service
170ms rc-local.service
167ms sys-fs-fuse-connections.mount
127ms systemd-tmpfiles-setup.service
110ms systemd-random-seed.service
65ms systemd-update-utmp-runlevel.service

#16

The current default image: http://beagleboard.org/latest-images

debian@beaglebone:~$ uname -r
4.14.71-ti-r80
debian@beaglebone:~$ bluetoothctl 
[NEW] Controller 98:7B:F3:13:30:C8 beaglebone [default]
[bluetooth]# scan on
Discovery started
[CHG] Controller 98:7B:F3:13:30:C8 Discovering: yes
[NEW] Device 4E:FB:D7:56:77:7B 4E-FB-D7-56-77-7B
[NEW] Device 56:D5:3E:02:5B:F7 56-D5-3E-02-5B-F7
[NEW] Device 5C:F3:70:8E:75:74 DESKTOP-TJ4283Q
[bluetooth]# exit
[DEL] Controller 98:7B:F3:13:30:C8 beaglebone [default]
debian@beaglebone:~$ dmesg | grep tooth
[   88.761989] Bluetooth: Core ver 2.22
[   88.762217] Bluetooth: HCI device and connection manager initialized
[   88.762251] Bluetooth: HCI socket layer initialized
[   88.762266] Bluetooth: L2CAP socket layer initialized
[   88.762321] Bluetooth: SCO socket layer initialized
[   88.868848] Bluetooth: HCI UART driver ver 2.3
[   88.868871] Bluetooth: HCI UART protocol H4 registered
[   88.880708] Bluetooth: HCI UART protocol LL registered
[   88.880727] Bluetooth: HCI UART protocol ATH3K registered
[   88.880734] Bluetooth: HCI UART protocol Three-wire (H5) registered
[   88.880740] Bluetooth: HCI UART protocol QCA registered
[   90.111596] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   90.111614] Bluetooth: BNEP filters: protocol multicast
[   90.111650] Bluetooth: BNEP socket layer initialized
debian@beaglebone:~$ systemctl status bb-wl18xx-bluetooth.service
● bb-wl18xx-bluetooth.service - BB WL18xx Bluetooth Service
   Loaded: loaded (/lib/systemd/system/bb-wl18xx-bluetooth.service; enabled; ven
   Active: active (running) since Fri 2019-04-12 17:06:28 UTC; 51s ago
  Process: 2104 ExecStart=/usr/bin/bb-wl18xx-bluetooth (code=exited, status=0/SU
 Main PID: 2155 (hciattach)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bb-wl18xx-bluetooth.service
           └─2155 /usr/bin/hciattach /dev/ttyS3 texas 300000

Apr 12 17:06:21 beaglebone systemd[1]: Starting BB WL18xx Bluetooth Service...
Apr 12 17:06:22 beaglebone bb-wl18xx-bluetooth[2104]: Found a Texas Instruments'
Apr 12 17:06:22 beaglebone bb-wl18xx-bluetooth[2104]: Firmware file : /lib/firmw
Apr 12 17:06:22 beaglebone bb-wl18xx-bluetooth[2104]: Loaded BTS script version 
Apr 12 17:06:22 beaglebone bb-wl18xx-bluetooth[2104]: texas: changing baud rate 
Apr 12 17:06:28 beaglebone bb-wl18xx-bluetooth[2104]: Device setup complete
Apr 12 17:06:28 beaglebone systemd[1]: Started BB WL18xx Bluetooth Service.

and with 4.19.19-bone-rt-r21

debian@beaglebone:~$ uname -r
4.19.19-bone-rt-r21
debian@beaglebone:~$ bluetoothctl 
[NEW] Controller 98:7B:F3:13:30:C8 beaglebone [default]
[NEW] Device 4B:38:82:0E:15:C3 4B-38-82-0E-15-C3
[NEW] Device 41:01:23:24:A9:08 41-01-23-24-A9-08
[bluetooth]# scan on
Discovery started
[CHG] Controller 98:7B:F3:13:30:C8 Discovering: yes
[NEW] Device 56:D5:3E:02:5B:F7 56-D5-3E-02-5B-F7
[CHG] Device 41:01:23:24:A9:08 RSSI: -85
[NEW] Device 6B:E8:E9:1E:43:7C 6B-E8-E9-1E-43-7C
[bluetooth]# exit
[DEL] Controller 98:7B:F3:13:30:C8 beaglebone [default]
debian@beaglebone:~$  dmesg | grep tooth
[  108.982024] Bluetooth: Core ver 2.22
[  108.982156] Bluetooth: HCI device and connection manager initialized
[  108.982177] Bluetooth: HCI socket layer initialized
[  108.982186] Bluetooth: L2CAP socket layer initialized
[  108.982219] Bluetooth: SCO socket layer initialized
[  109.013785] Bluetooth: HCI UART driver ver 2.3
[  109.013798] Bluetooth: HCI UART protocol H4 registered
[  109.013877] Bluetooth: HCI UART protocol LL registered
[  109.013881] Bluetooth: HCI UART protocol ATH3K registered
[  109.013923] Bluetooth: HCI UART protocol Three-wire (H5) registered
[  109.263269] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  109.263280] Bluetooth: BNEP filters: protocol multicast
[  109.263301] Bluetooth: BNEP socket layer initialized
debian@beaglebone:~$ systemctl status bb-wl18xx-bluetooth.service
● bb-wl18xx-bluetooth.service - BB WL18xx Bluetooth Service
   Loaded: loaded (/lib/systemd/system/bb-wl18xx-bluetooth.service; enabled; ven
   Active: active (running) since Fri 2019-04-12 17:15:05 UTC; 57s ago
  Process: 2005 ExecStart=/usr/bin/bb-wl18xx-bluetooth (code=exited, status=0/SU
 Main PID: 2035 (hciattach)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/bb-wl18xx-bluetooth.service
           └─2035 /usr/bin/hciattach /dev/ttyS3 texas 300000

Apr 12 17:15:03 beaglebone systemd[1]: Starting BB WL18xx Bluetooth Service...
Apr 12 17:15:03 beaglebone bb-wl18xx-bluetooth[2005]: Found a Texas Instruments'
Apr 12 17:15:03 beaglebone bb-wl18xx-bluetooth[2005]: Firmware file : /lib/firmw
Apr 12 17:15:03 beaglebone bb-wl18xx-bluetooth[2005]: Loaded BTS script version 
Apr 12 17:15:03 beaglebone bb-wl18xx-bluetooth[2005]: texas: changing baud rate 
Apr 12 17:15:05 beaglebone bb-wl18xx-bluetooth[2005]: Device setup complete
Apr 12 17:15:05 beaglebone systemd[1]: Started BB WL18xx Bluetooth Service.

So feel free to utilize the default kernel config, your still cutting too much…

Start with the base config and on each removal retest…

Regards,

#17

Hello,
I follw the below procudure to make totall new image without any cutting.
It seems there missed some bluetooth protocol support and I am not clear whether need to enable some config during building kernel or need apt install some extra pkg.
Thanks for your support.

https://www.digikey.com/eewiki/display/linuxonarm/BeagleBone+Black#BeagleBoneBlack-Setuname_rin/boot/uEnv.txt.
config4.14.93-bone-rt-r17.txt (150.7 KB)

root@arm:/boot# /opt/scripts/tools/version.sh
git:/opt/scripts/:[38ce81fcdafad0892b6c485acd4e9a2245dfb07a]
eeprom:[A335BNLTBWA51905BBWG0309]
model:[TI_AM335x_BeagleBone_Black_Wireless]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2019.01-dirty]:[location: dd MBR]
bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2018.09-00002-g0b54a51eee]:[location: dd MBR]
kernel:[4.14.93-bone-rt-r17]
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[enable_uboot_cape_universal=1]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade ]
pkg:[bb-cape-overlays]:[4.4.20190215.0-0rcnee0~stretch+20190215]
pkg:[bb-wl18xx-firmware]:[1.20190227.1-0rcnee0~stretch+20190227]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
WARNING:pkg:[librobotcontrol]:[NOT_INSTALLED]
pkg:[firmware-ti-connectivity]:[20180825+dfsg-1rcnee1~stretch+20181217]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c netdev gpio pwm eqep bluetooth admin spi tisdk weston-launch xenomai cloud9ide]
cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait coherent_pool=1M net.ifnames=0 optargs=quiet lpj=1990656]
dmesg | grep pinctrl-single
[ 0.457168] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
dmesg | grep gpio-of-helper
[ 0.462742] gpio-of-helper ocp:cape-universal: ready
END

root@arm:/boot# dmesg |grep tooth
[ 9.369276] Bluetooth: Core ver 2.22
[ 9.480157] Bluetooth: HCI device and connection manager initialized
[ 9.514612] Bluetooth: HCI socket layer initialized
[ 9.593102] Bluetooth: L2CAP socket layer initialized
[ 9.650258] Bluetooth: SCO socket layer initialized
[ 20.095689] Bluetooth: HCI UART driver ver 2.3
[ 20.114109] Bluetooth: HCI UART protocol H4 registered
[ 20.125525] Bluetooth: HCI UART protocol ATH3K registered
[ 20.135065] Bluetooth: HCI UART protocol Three-wire (H5) registered

root@arm:/boot# systemctl status bb-wl18xx-bluetooth.service
● bb-wl18xx-bluetooth.service - BB WL18xx Bluetooth Service
Loaded: loaded (/lib/systemd/system/bb-wl18xx-bluetooth.service; enabled; vendor prese
t: enabled)
Active: inactive (dead) since Mon 2019-04-15 15:17:18 CST; 27min ago
Process: 678 ExecStart=/usr/bin/bb-wl18xx-bluetooth (code=exited, status=0/SUCCESS)

Apr 15 15:17:17 arm systemd[1]: Starting BB WL18xx Bluetooth Service…
Apr 15 15:17:17 arm bb-wl18xx-bluetooth[678]: Found a Texas Instruments’ chip!
Apr 15 15:17:17 arm bb-wl18xx-bluetooth[678]: Firmware file : /lib/firmware/ti-connectivi
ty/TIInit_11.8.32.bts
Apr 15 15:17:17 arm bb-wl18xx-bluetooth[678]: Loaded BTS script version 1
Apr 15 15:17:17 arm bb-wl18xx-bluetooth[678]: texas: changing baud rate to 3000000, flow
control to 1
Apr 15 15:17:18 arm bb-wl18xx-bluetooth[678]: Can’t set device: Protocol not supported
Apr 15 15:17:18 arm bb-wl18xx-bluetooth[678]: Can’t initialize device: Protocol not suppo
rted
Apr 15 15:17:18 arm systemd[1]: Started BB WL18xx Bluetooth Service.
root@arm:/boot#

#18

@springzhang

I’m confused, what guide are you following? You’ve jumped between, 4.19.19-bone-rt-r21, 4.14.79-ti-rt-r86, and now 4.14.93-bone-rt-r17…

and yes, i can confirm 4.14.93-bone-rt-r17 shows this issue:

debian@beaglebone:~$ uname -r
4.14.93-bone-rt-r17
debian@beaglebone:~$ journalctl | grep bb-wl18xx-bluetooth
Apr 15 15:25:32 beaglebone bb-wl18xx-bluetooth[1056]: Found a Texas Instruments' chip!
Apr 15 15:25:32 beaglebone bb-wl18xx-bluetooth[1056]: Firmware file : /lib/firmware/ti-connectivity/TIInit_11.8.32.bts
Apr 15 15:25:32 beaglebone bb-wl18xx-bluetooth[1056]: Loaded BTS script version 1
Apr 15 15:25:32 beaglebone bb-wl18xx-bluetooth[1056]: texas: changing baud rate to 3000000, flow control to 1
Apr 15 15:25:33 beaglebone bb-wl18xx-bluetooth[1056]: Can't set device: Protocol not supported
Apr 15 15:25:33 beaglebone bb-wl18xx-bluetooth[1056]: Can't initialize device: Protocol not supported

But at this point, you should be using v4.19.x anyways…

Regards,

#19

Sorry. Let me make it more clear.
My goal is to make minimal RTLinux image with booting time as short as possible.
I had built two versions of 4.19.19-bone-rt-r21, 4.14.79-ti-rt-r86 with some cutting before as the below procedure for beagleboneblack Rev C.
https://www.digikey.com/eewiki/display/linuxonarm/BeagleBone+Black#BeagleBoneBlack-Setuname_rin/boot/uEnv.txt
For now, I change to beagleboneblack wireless and I try to use previous image but failed to enable bluetooth.
So as your instructions, I just rebuild the image of 4.14.93-bone-rt-r17 without any cutting and show issues above.
Could you tell me how to go ahead at this point?
1, apt install linux-image-4.19.19-bone-rt-r21 on top of 4.14.93-bone-rt-r17
2, rebuild new image of linux-image-4.19.19-bone-rt-r21?
3, any other fix?

Thanks much!

#20

For your reference.
I apt install linux-image-4.19.19-bone-rt-r21 on top of 4.14.93-bone-rt-r17 but happen another error.
Finally I find the below solution
change value from 1 to 0 in this file /var/lib/systemd/rfkill/platform-481a6000.serial:bluetooth.

root@arm:/var/lib/systemd/rfkill# systemctl status bb-wl18xx-bluetooth.service
● bb-wl18xx-bluetooth.service - BB WL18xx Bluetooth Service
   Loaded: loaded (/lib/systemd/system/bb-wl18xx-bluetooth.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since Fri 2016-11-04 01:18:42 CST; 3min 36s ago
  Process: 1071 ExecStart=/usr/bin/bb-wl18xx-bluetooth (code=exited, status=0/SUCCESS)
Nov 04 01:18:39 arm systemd[1]: Starting BB WL18xx Bluetooth Service...
Nov 04 01:18:40 arm bb-wl18xx-bluetooth[1071]: Found a Texas Instruments chip!
Nov 04 01:18:40 arm bb-wl18xx-bluetooth[1071]: Firmware file : /lib/firmware/ti-connectivity/TIInit_11.8.32.bts
Nov 04 01:18:40 arm bb-wl18xx-bluetooth[1071]: Loaded BTS script version 1
Nov 04 01:18:40 arm bb-wl18xx-bluetooth[1071]: texas: changing baud rate to 3000000, flow control to 1
Nov 04 01:18:42 arm bb-wl18xx-bluetooth[1071]: Can't init device hci0: Operationnot possible due to RF-kill (132)Can't initialize device: Operation not possible due to RF-kill
Nov 04 01:18:42 arm systemd[1]: Started BB WL18xx Bluetooth Service.