I need help ordering the correct capacitors

I have this circuit board that I have removed these 6 numbered capacitors from. I need help identifying them so that I can order the correct replacements. I have tried to take blown up pictures of the technical data to aid in figuring out what they are. Caps 2-4 are the same. The blue caps have a lead spacing of 15 mm and the gray ones have a spacing of 9.75mm. I would appreciate any help you can provide. Thank you

Please help as this is a partial solution.

Hello jhoman,

CAUTION: We are dealing with a line powered device. This presents an electrocution hazard. It also presents a safety hazard of fire, electrocution, or explosion if the wrong capacitors are chosen.
Several of the capacitors you identified fall under the category of “safety capacitor.” You can identify these critical capacitors by the “X” and “Y” rating. The video at the end of this note introduces the X and Y safety capacitors:

I was able to identify the gray capacitors. The DigiKey part numbers are included in the picture at the end of this note.

The Blue capacitors are manufactured by EPCOS (TDK Electronics), but I am unable to cross the part numbers. I’ve narrowed it down to these 148 results:

By chance is there any additional writing on the blue capacitors. Please let us know as that would help narrow the search.

Also, there may be another community member who is more familiar with the EPCOS part number.

Best Wishes,


This is what is on the side of the blue caps. Thank you for your assistance so far, I really appreciate it.

This is the information on the side of the blue caps. Thanks very much for your efforts.


Hi jhoman,

I’m pretty certain that cap 1, with the C0-U33 M marking, is a 0.33uF, ±20%, X2, -40°C ~ 105°C, capacitor. Here’s a link to similar ones we have. They vary in dimensions, temperature (105°C or higher), tolerance (±10% or ±20%), and additional automotive ratings.

Capacitor 6, the one with the D3-U15 M marking, is a 0.15uF, ±20%, X2, -40°C ~ 105°C, capacitor. Here’s the link to similar ones we carry. They vary in dimensions, temperature (105°C or higher), tolerance (±10% or ±20%), and additional automotive ratings.

1 Like

Thanks very much, that is the information I was needing. I should be able to match up a part with similar dimensions. Hopefully they will get my board running again.

Did you fix work? I have the same device as you, Enphase Envoy, and my microinverters are no longer reporting correctly. Maybe the problem that I have is the same as the problem that you had?

My device’s wifi failed about a year ago and I was able to fix it using an external WiFi adapter that I bought online. That got it connected to the Internet but just a month ago the microinverters are no longer reporting. The display on the device is still fine and the wifi is still fine, too.

I’d love to hear how your repair went and what was wrong! Thanks.

Yes the fix worked. I had a similar issue with a LG TV having the HDMI ports not working. The fix for that TV was to take out the mother board and bake it in the oven at 400 degrees for 10 minutes and then when reinstalled it would work for some period of time. I must have reflowed that TV at least 10 times because it would always revert back to the same problem. I figured I had nothing to loose with my Envoy because I could not come up with any other fix for it. I took this Envoy motherboard and did the same thing with it. I did leave it in the oven a bit longer and this may be the reason why my caps melted. Once I replaced the 6 caps that I had damaged, the Envoy has worked since. Hopefully it won’t be like the TV and it stays fixed. I would suggest trying, let me know if it works for you too.

1 Like

Can you explain what the symptoms were before you did the fix? For me, the issue is that the microinverters are not detected. However, the LCD works fine and the wifi works fine, too. Is this similar to what you experienced?

I desoldered the radial electrolytic and it reads 44uF, which is not too far from the 47uF printed on it, not enough to fail it. I didn’t desolder and test all the XY caps yet but the ones that I’m able to test in circuit seem okay. All capacitors look okay physically.

For your replacement, you replaced just all those blue blocky ones?

Before I baked the board the display would power up but all the blocks were full on. Every pixel full. It did not do anything. After I baked it the board booted properly but would not recognize any micro inverters. Thats why I thought It might not be filtering out the noise to see the power line signal signal. I dont have the pictures in front of me but it replaced 6 caps. I think it was the 6 I labeled in the post. Blue and gray. I can be more specific if you need me to be but I am away from my PC at the moment.

These are the components I ordered to fix the fact that my Envoy could not see the micro inverters. It found them after I changed them out.

components.pdf (46.9 KB)

Cool man! Yeah, that makes sense about the filters. The capacitors are there to filter out the power line and what remains is the microinverter data. Okay, I’ll try that.

Wow in a good circuit design the film capacitors should last 50 or more years without failure. If two users have the same short time span failure of multiple film capacitors that indicates some pretty bad design flaws in the product.

1 Like

I did cook and melt mine in the oven at 400F, but felt it was necessary to potentially fix the other problem the board had. So far all problems have been resolved.

@PaulHutch I bought off the list that @jhoman provided. The good news is that all the sizing and values were correct. The bad news is that the fix didn’t work.

I used the “mikrocontroller AVR transistortester” (spelled just like that) to test the values of all capacitors and they were all pretty good. I think that there was one that had capacitance that was low by about 10% but that is still within tolerance. Film capacitors are quite reliable, especially with just small capacitance values. Usually it’s just the electrolytic ones from the capacitor plague that I worry about.

Soldering them was a pain in the ass. Maybe if I had a good Hakko with lots of thermal mass it would have been better but on my cheapy stick soldering iron, set to 400C, I had a hell of a time trying to remove a lead that was connected to a massive ground pour. I broke a lead and had to drill it out! Due to this, I tested my connections for connectivity before proceeding.

But like I said, all the removed caps were within tolerance so I had low hopes and, in the end, it didn’t help. Something else must have fried.

Hello eyalsoha,

A few weeks ago, I found this video. Perhaps it will help you desolder some of those difficult components.

Best Wishes,


1 Like

@APDahlen Maybe I’ll try that wire trick next time. For me, I wasn’t even able to get that one lead to flow!

I never thought to dip the wick in flux! That’s a good idea. I’ve never had good results with wick and I usually use the solder sucker. I’ll try it next time.


Can anyone identify the epcos component in this picture

I am not seeing an image posted.
You can add images by dragging them in to the text field when typing.

the image at the start of this post