Olimex imx233 time out (...\xc2\xa0.device)


#1

Hello! I was following the guide for compiling the kernel for the imx233 Olimex boards here: https://eewiki.net/display/linuxonarm/iMX233-OLinuXino

I built everything, loaded it onto the SD card and booted up my board. During startup I get a timeout: “Timed out waiting for device dev-mmcblk0p2\xc2\xa0.device.”

I checked fstab and confirmed that it has “/dev/mmcblk0p2 / auto errors=remount-ro 0 1”

Any ideas what may be wrong? Thanks

full logs here as bootup.txt (new users can’t post files): https://www.dropbox.com/s/xoq33vl8x91578l/bootup.txt?dl=0


#2

Hi Kevin,

I’m really surprised the imx23 even supports SDXC:

[    2.330000] mmc0: host does not support reading read-only switch, assuming write-enable
[    2.350000] mmc0: new high speed SDXC card at address aaaa
[    2.420000] mmcblk0: mmc0:aaaa SL64G 59.5 GiB 
[    2.480000]  mmcblk0: p1 p2

That’s pretty cool. Sadly all my imx23’s are at work, so i can’t check this out till tomorrow.

But can you double check your /etc/fstab setting? as it did get close to the login prompt.

edit: okay i see you double checked your fstab settings.

What OS was your host that you built the microSD card with, sfdisk and mkfs.ext4 versions?

Regards,


#3

Hi Robert,
Yep, I googled my question before asking and saw your previous answers (for beagle bones though)! Using Ubuntu 16.04 host, sfdisk from util-linux 2.27.1, mkfs.ext4 1.42.13

Thanks


#4

Hi Kevin,

That combination should have worked. Any chance do you have an SDHC card? I dug thru my hardware pile and found an imx23. But my only SDXC card is ‘ro’ and no longer taking a format…

Here’s my boot log, with a 16GB microSD:

imx23-v4.9.x-boot.log (16.9 KB)

debian@arm:~$ dmesg | grep mmc
[    0.000000] Kernel command line: console=ttyAMA0,115200 root=/dev/mmcblk0p2 ro rootfstype=ext4 rootwait fixrtc
[    2.080000] 80010000.ssp supply vmmc not found, using dummy regulator
[    2.150000] mxs-mmc 80010000.ssp: initialized
[    2.300000] mmc0: host does not support reading read-only switch, assuming write-enable
[    2.320000] mmc0: new high speed SDHC card at address e624
[    2.360000] mmcblk0: mmc0:e624 SU16G 14.8 GiB 
[    2.400000]  mmcblk0: p1 p2
[    2.540000] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
[   10.410000] EXT4-fs (mmcblk0p2): re-mounted. Opts: errors=remount-ro
debian@arm:~$ uname -r
4.9.14-imxv5-r1

Regards,


#5

Hi Robert,
Still have the same problem with a SDHC card. I noticed a reported CRC error at the top of the logs:

CPU:   Freescale i.MX23 rev1.4 at 454 MHz
BOOT:  SSP SD/MMC #0
DRAM:  64 MiB
No arch specific invalidate_icache_all available!
__led_init: failed requesting GPIO59!
MMC:   MXS MMC: 0
*** Warning - bad CRC, using default environment

What CRC check failed? My rootfs checksum matched the one on your site. Kernel is corrupted? It should be noted that I tried this with both 4.10 and 4.9 kernels and had the same issues.


#6

Ah wait, I just checked your logs and you have the same CRC thing, so it shouldn’t be an issue I guess.


#7

U-Boot will allow you to save the environment (aka changes/additions) for future boots. In our case, we are just using the default settings. The CRC fails, since that location is “blank”…

Regards,


#8

Hm ok. The only thing I changed is I also include some non-default kernel modules. In menuconfig in Device Drivers under PPS, I selected all the modules in that submenu. I’m trying to compile everything again without selecting those, going to see if that makes a difference


#9

Still broken following everything to a t. No extra modules loaded or anything :frowning:


#10

Do you have any ideas what’s wrong here? I’m really stuck on this.


#11

Hi Kevin,

No nothing off hand. When i tested the kernel image a few days ago i had rebuilt everything as written from the wiki. (I’m using Debian Buster amd64)

sudo sfdisk -v
sfdisk from util-linux 2.29.2

sudo mkfs.ext4 -V
mke2fs 1.43.4 (31-Jan-2017)
	Using EXT2FS Library version 1.43.4

The only thing it might be:

https://eewiki.net/display/linuxonarm/iMX233-OLinuXino#iMX233-OLinuXino-CopyRootFileSystem

sudo tar xfvp ./debian-*-*-armel-*/armel-rootfs-*.tar -C /media/rootfs/
sync
sudo chown root:root /media/rootfs/
sudo chmod 755 /media/rootfs/

During the Debian Stretch development, the chown and chmod call’s became required. But without them, it only broke the default user permissions.

Regards,

edit: tongue tied…