Snap-off


#1

How does one turn off snap in scheme-it?


#2

Hello, Juanito.

Could I ask what you mean by ‘snap’? What feature are you trying to deactivate?


#3

This is a feature of all CAD systems that as you bring an object close to a certain point (such as a point on the grid) it will automatically SNAP to that point, even if the connection isn’t there. Scheme-it seems to have a problem in that the parts objects don’t align with the wire objects if the snap feature is turned on. Turning it off allows a smooth movement of the object you are dragging to wherever you want. I am getting the impression that this isn’t an option in Scheme-it, but something I’m going to have to figure a work-around on. Turning off the grid didn’t help either. I’m not sure yet what the line or object is snapping to. Also, I find I can’t draw the line (wire) until the parts object is in place.


#4

Hm. Every time I’ve used Scheme-It, parts have naturally moved on the grid. Scheme-It is based on grid positioning even when the grid isn’t shown; parts cannot be placed anywhere but on grid points. Same for wires or nodes. In this instance I don’t believe there’s a way to disable the snap behavior you’re speaking of, no. Sorry, Juanito.

As for wires/lines, you are correct. Currently Scheme-It does not permit users to draw free-floating wires hanging off of a part and connecting to nothing. I’ve used ‘PORT, NODE’ in Schematic Symbols > Ports, a small circular symbol, as a placeholder part when I want to draw a wire that goes to nothing, or as an Output symbol for circuits that want it. This one:

PORT%20NODE

Beyond this, unfortunately there’s no method yet for drawing an unconnected wire. Let me know if there’s anything else I can help with.