STM32F3 Discovery kit unable to show usb device drivers

Hello Tech Support.

I just ordered 40 units and used 1 usb min b to usb a cable connected to my windows 10 pc, and unable to see the usb ports? I also connected to ubuntu Linux, lsusb -t is not recognized. Please let me know what to do?



I would recommend seeing if the drivers the manufacturer lists for that item would help.

image when I connected ST-LINK/V2

However, after removed ST-LINK/V2, and connected to STM32F3 Discovery device, show this error:

Is any driver installer to install this usb device driver? Can you send me the download link?

Hello Hong,

I am sorry about the issues you are having. I tried to find the issue. I got the e-mail. Though I think this will be better on the Forum as I have more people to look at it. I am sending an internal request on the Forum for someone to check this. I am sure it is a setting issue if all of them are not working. One of the Engineers will respond on the Forum.

1 Like

Hi @hong.chen 's @Nathan_2268’s post above (STM32F3 Discovery kit unable to show usb device drivers - #2 by Nathan_2268) is where you can obtain ST’s driver:

You have to create an account with ST to download the software driver, this is ST’s requirements on their website…


Is this the kit you ordered?

Which usb are you connecting A or B in this picture ^^^…


Thanks for your support. I ordered STM32F3DISCOVERY (DK32F303C$AX1), which connected USB min B port on “A” STM board to USB A port on my PC.

Is this driver STSW-LINK009 - ST-LINK, ST-LINK/V2, ST-LINK/V2-1, STLINK-V3 USB driver signed for Windows7, Windows8, Windows10 - STMicroelectronics supports STM32F303?

I downloaded the driver installer and still face same error:

Please let me know if the usb 2.0 port and devices can be recognized in Ubuntu Linux or not, that means type lsusb -t is able to display port and device with “communications” class and CDC data ports or not, if not could you please let me know which one can support, I have to replace these 40 units asap.

Hi Robert,
This is a very urgent issue, please let me know if it is not work I have to return, otherwise, I need to keep 40 and will order more. Thanks

Hi @hong.chen Port A, is (USB-USER), this is the USB port you would use in your application design. There is no ‘fixed’ driver for it, as it’s up to you in the design of your software/etc to also create a matching driver for your application…

Port B (USB ST-Link) would use the standard USB drivers from ST to communicate with the on board ST-Link.

If you want an example to test USB A…

Then flash this example…

Which should be a USB Hid example… (using windows built in usb hid (and linux’s) driver…)


Thanks for your response. So I have to flash all of 40 units to be able to show usb ports on windows and Linux?

BTW, how to load this hex file into STM32F303Discovery board? Is any detail steps to follow?


Yes. See @RobertCNelson’s response.

The STM32CubeProgrammer software is the recommended tool.

You can’t get much more detailed than the user manual (UM2237). The basic steps are:

  1. Plug in the board (with USB ST-LINK)
  2. Click Connect.
  3. Open the .hex file.
  4. Click Download.

No, that is incorrect… Port B (labeled USB ST-Link) only needs the ST Drivers…

Port A (USB-USER) is for your application to use, by default it’s not used, till your application uses it.

ST’s flashing tool is here:

Just plug in the Port B (USB-Stlink), and use the tool ^…


Thank you Robert for your support! I installed the STM tool and upload this hex file, and be able to see usb ports. I will test it.

I was looking for a solution to the same problem, I am going to try all the recommendations that you have been given to solve mine

Can we change SW only show 2 end points not 4?

       |__ Port 3: Dev 20, If 0, Class=Hub, Driver=hub/4p, 480M
            |__ Port 4: Dev 26, If 2, Class=Communications, Driver=cdc_acm, 12M
            |__ Port 4: Dev 26, If 0, Class=Vendor Specific Class, Driver=, 12M
            |__ Port 4: Dev 26, If 3, Class=CDC Data, Driver=cdc_acm, 12M
            |__ Port 4: Dev 26, If 1, Class=Mass Storage, Driver=usb-storage, 12M