STM32MP1 - Can't see the built kernel version number


I want to install Ubuntu LTS 18.04 on a STM32MP157C-DK2.

After having correctly installed Linaro GCC and U-Boot on my host Linux PC, I have to build the kernel to be used by the STM32MP1 device.

When running (from, branch v5.3.x), I understood that the kernel version number is supposed to be shown in the following format :

Script Complete [user@localhost:~$ export kernel_version=4.X.Y-Z]

When I run, it didn’t seem to fully execute correctly, as it end by :

CC [M] drivers/usb/serial/whiteheat.o
CC [M] drivers/usb/serial/xsens_mt.o
LD [M] drivers/usb/serial/usbserial.o
AR drivers/usb/built-in.a
AR drivers/scsi/built-in.a
AR drivers/built-in.a
[martin@NestingSafe armv7-lpae-multiplatform]$

Resulting that I can’t see the kernel_version number that I’m supposed to use right after.

May someone who already faced this issue help me with that ?

Something in the build failed… Please run this command, such that only one 1 thread is used.

CORES=1 ./tools/


Thank you for answering that fast !

The result of this command line is :

[martin@NestingSafe armv7-lpae-multiplatform]$ CORES=1 ./tools/
+ Detected build host ["Manjaro Linux"]
+ host: [x86_64]
+ git HEAD commit: [0178e9aa15466b238c9a6729f237658b55d85908]
scripts/gcc: Using: arm-linux-gnueabihf-gcc (GNU Toolchain for the A-profile Architecture 8.3-2019.03 (arm-rel-8.36)) 8.3.0
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
scripts/kconfig/mconf  Kconfig
*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.
'.config' -> '/home/martin/armv7-lpae-multiplatform/patches/defconfig'
make -j1 ARCH=arm LOCALVERSION=-armv7-lpae-x3 CROSS_COMPILE="/home/martin/armv7-lpae-multiplatform/dl/gcc-arm-8.3-2019.03-x86_64-arm-linux-gnueabihf/bin/arm-linux-gnueabihf-"  zImage modules
  CALL    scripts/
  CALL    scripts/atomic/
  CHK     include/generated/compile.h
  CC      kernel/configs.o
  AR      kernel/built-in.a
  CHK     kernel/kheaders_data.tar.xz
  GEN     kernel/kheaders_data.tar.xz
./kernel/ ligne 61: cpio : commande introuvable
make[1]: *** [kernel/Makefile:131: kernel/kheaders_data.tar.xz] Error 127
make: *** [Makefile:1083: kernel] Error 2
[martin@NestingSafe armv7-lpae-multiplatform]$

Your the 2nd users i’ve had questions on this distribution, i really need to install it in a vm and take a look at things…

Install cpio


I also had to install lzop and it worked. The kernel built successfully !

Thank you very much, now I keep going on with the Root File System…

Hey, Ubuntu successfully installed on the MP1 from Manjaro :slight_smile:

I added a quick check here:

Still building in Manjaro, so I’ll probably still have to add a few more pkg checks…


1 Like

Glad to hear it !

Ubuntu successfully booted, but it seems like the USB isn’t working at the moment.


Correct, USB is not fully working yet, there’s patches for u-boot, haven’t found any for the kernel yet…