5GHZ WiFi BBB


#1

5GHz has issues, particularly with the bb-kernel build. The TI AM335x BeagleBone Black Gateway Cape has a WL1837 (2.4G & 5G). The build shows the two bands but band 2 shows no frequencies. I traced this to inclusion of /lib/firmware/ti-connectivity/wl18xx-conf.bin. I suspect this is a calibration file required for older chip sets but optional for the 1837. I am assuming no 5GHz calibration data is present in this old file. Removal of this file causes the driver to use (hopefully sane) defaults. With removal 5GHz iw now shows frequencies. It is also looks like the init script may use the wrong firmware for the “TI AM335x BeagleBone Black Gateway Cape” options, why not wl18xx-fw?

I am still reviewing this but any help from the community would be appreciated.


#2

Hi @dfarrell i guess i never noticed Embest stuck a 5Ghz wl1837 on their cape.

The firmware we assume for these devices does not have the 5Ghz Antenna Wired up: (aka assumes wl1835)

 |NumberOfAssembledAnt2_4     |= 02 # Indicates the active bands and the number of mounted antennas for 2.4GHz;  |
|---|---|
|NumberOfAssembledAnt5       |= 00 # Indicates the active bands and the number of mounted antennas for 5GHz;|

Here is TI’s WL1837MOD_INI_FCC_CE.ini:
https://git.ti.com/wilink8-wlan/18xx-ti-utils/blobs/master/wlconf/official_inis/WL1837MOD_INI_FCC_CE.ini

From my notes, i generated “wl18xx-conf.bin”

wlconf -o /lib/firmware/ti-connectivity/wl18xx-conf.bin -I WL1835MOD_INI_C2PC.ini

Using R8.6SP1 of : http://git.ti.com/cgit/cgit.cgi/wilink8-wlan/18xx-ti-utils.git/log/

Here is my branch to get things building on debian:

Regards,


#3

Robert,

I also found that the Debian crda package must be installed for iw reg get / set to work. Without this no, 5GHz. Now on to configure higher speed options…

Thanks for your excellent support!

David.


#4

So this is what I needed, I did this native on the BBB:

git clone https://github.com/rcn-ee/ti-18xx-ti-utils.git
wget http://www.infradead.org/~tgr/libnl/files/libnl-2.0.tar.gz

libnl needs bison (and I assume flex) installed. libnl takes a few minutes to build.
tar xzf libnl-2.0.tar.gz
cd libnl-2.0
.configure
make
sudo make install

cd …/ti-18xx-ti-utils
make
sudo make install

The above only seems to build calibrator and puts it in /usr/bin

cd wlconf
make

now from the folder where wlconf is build, there is the subfolder official_inis

I need FCC, CE and Japan for my application.

./wlconf -o wl18xx-conf.bin -I official_inis/ WL1837MOD_INI_FCC_CE_JP.ini

sudo cp wl18xx-conf.bin /lib/firmware/ti-connectivity

I verified 5GHz still worked. I did not try higher speed settings, different bandwidths yet.

David.