[BBB] X and Y axis inverted using xinput calibrator on ubuntu 20.04 LTS

Hi Robert,

I am attempting to calibrate the touch screen using xinput calibrator utility.
There are a few things to observe: if we move our finger horizontally to the right, the cursor moves to the left, and vice versa.
The same is applicable for vertical locations.
I modified a couple of options in 99-calibration.conf file. I did not see any difference,

Here is my configuration file

Section “InputClass”
Identifier “calibration”
MatchProduct “Microchip TSHARC TouchScreen”
Option “MinX” “62490”
Option “MaxX” “5912”
Option “MinY” “59826”
Option “MaxY” “5760”
Option “SwapXY” “0” # unless it was already set to 1
Option “InvertX” “1” # unless it was already set
Option “InvertY” “1” # unless it was already set

Please provide your suggestions/views.


Hi @chougulemrudula the xinput-calibrator project is pretty much dead at this point…

For the in kernel ar1021 driver, we use the generic touch screen options to flip and rotate…


Here’s a script we used back in v3.8.x (2018~ish)…

it should pop up a window for you to press different zones, and dump a calibration file.



I am trying to run xinput_calibrator_pointercal.sh script. I observed below messages,

$sudo ./xinput_calibrator_pointercal.sh
[sudo] password for test:
No protocol specified
Unable to connect to X server
No protocol specified
Unable to connect to X server
No protocol specified
Unable to connect to X server

Are you running from X? it won’t work over ssh or serial…

xinput_calibrator --list


I am running over ssh. I will try running it from the terminal.

xinput_calibrator --list
Device “Microchip TSHARC TouchScreen” id=7

I tried running from the terminal… and i get below errors
Unable to connect to X server

So while running from a terminal in your X Windows manager run: (not ssh or serial)…

xinput_calibrator --device 7

Should popup a finger selection gui…

PS, looking at my notes, i gave up on xinput-calibrator script in Debian Stretch 9.x:

Looks like i was unable to pass the xinput data back to xorg at that time…

Edit 2:

I see a pull request for libinput for a newer xorg

along with a bunch of other fixes:



I tried in terminal (alt+ctlr+F1) and got the same error “Unable to connect to x server”

can we use xinput set-props? if yes how can we make it permanent?