BBBL -unable to upgrade/install on new 18.04-ROS IOT image


#1

Beagle Bone Blue (EduMIP)
Installed bone-ubuntu-18.04.1-ros-iot-armhf-2018-11-25-6gb.img

Tried to sudo apt upgrade and the system will Get several packages and then produce the many errors saying
“Could not open file x,…xx.deb - open (30: Read-only file system) [IP: xxx:: 80]”
there after anything typed returns “-bash: /usr/bin/clear: Input/output error” and a reboot is required.

Google searches indicated either a disk or file system problem. I have tried multiple sd cards and get the same results with each.
The Debian-Stretch works on the BBBl so I suspect the file system. I have exhausted all of my google skills searching for fixes.
Would appreciate help in troubleshooting and resolving this problem
Thanks


#2

@kenden, the ROS image uses the RT variant (https://wiki.linuxfoundation.org/realtime/start) of the kernel that is currently used for all the beagleboard.org images. What brand/version of microSD cards are you using? I’m usally testing with SandDisk Extreme/Ultra/Pro’s… Currently one of v4.14.x-rt-ti’s trademark features is being really really slow in the mmc block layer. We’ve got a fresh release available on https://rcn-ee.net/rootfs/bb.org/testing/ (2018-12-10)… I’m starting to test v4.19.x-rt-ti as a replacement for the current v4.14.x-rt-ti based kernel that ships in ROS.

Regards,


#3

Just an update on 2018-11-25, doesn’t seem to be a disk size issue… sudo apt update ; sudo apt upgrade work fine in the default image…

beagle@beaglebone:~$ df -h | grep mmcblk0p1
/dev/mmcblk0p1  4.9G  3.3G  1.4G  72% /

Reading state information... Done
154 packages can be upgraded. Run 'apt list --upgradable' to see them.

154 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 48.5 MB of archives.
After this operation, 331 kB disk space will be freed.
Do you want to continue? [Y/n]

Setting up ros-melodic-viz (1.4.1-0bionic.20181118.054150) ...
Setting up ros-melodic-visualization-tutorials (0.10.3-0bionic.20181118.054406) ...
Setting up ros-melodic-desktop (1.4.1-0bionic.20181118.054808) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
beagle@beaglebone:~$ 

beagle@beaglebone:~$ df -h | grep mmcblk0p1
/dev/mmcblk0p1  4.9G  3.5G  1.2G  75% /

Regards,


#4

If I read this correctly, you suspect the speed of the memory cards to be causing the errors.
I have be working with both a ScanDisk C4 and PNY C10 cards ( both 16gb).

I have an ScanDisk ultra plus xc1 C10 card that I will try. Is the kernel for the (2018-12-10) the v4.19?

Thanks!


#5

@kenden, nope still v4.14.x, still need testing on v4.19.x…

Debian ROS Image

Regards,


#6

Purchased a new 32 gb sd card with “100MB/s” speeds.
Installed the 12-10 image.
The update and upgrade when fine - nothing to do…

Tried to install GAZEBO using the step x step instructions as shown on
http://gazebosim.org/tutorials?tut=install_ubuntu&cat=install
Which broke due to unmet dependencies [E: Unable to correct problems, you have held broken packages]

Installed aptitude.

While trying to resolve the dependencies, I was using aptitude to resolve and install various packages but end up with the same Read-Only error after some number of Get: package

After a reboot I can repeat with similar results.

no joy.


#7

@kenden, it would probally be best to bug the gazebo guys… There repo is broken…

beagle@beaglebone:~$ sudo apt install gazebo9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gazebo9 : Depends: gazebo9-common (= 9.4.1-1~bionic) but it is not going to be installed
           Recommends: gazebo9-plugin-base but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Regards,


#8

will do. thanks for your assistance.