Beagle Bone Blue Issue


#1

I have followed the instructions found here:
https://eewiki.net/display/linuxonarm/BeagleBone+Blue#BeagleBoneBlue-Ubuntu16.04LTS

But I am stuck on the following three Steps:
Copy Kernel Image:
sudo cp -v ./ti-linux-kernel-dev/deploy/{kernel_version}.zImage /media/rootfs/boot/vmlinuz-{kernel_version}

returns:
cp: cannot stat ‘./ti-linux-kernel-dev/deploy/4.10.0-28-generic.zImage’: No such file or directory

Copy Kernel Device Tree Binaries:
sudo tar xfv ./ti-linux-kernel-dev/deploy/{kernel_version}-dtbs.tar.gz -C /media/rootfs/boot/dtbs/{kernel_version}/

returns:
tar: ./ti-linux-kernel-dev/deploy/4.10.0-28-generic-dtbs.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

Copy Kernel Modules:
sudo tar xfv ./ti-linux-kernel-dev/deploy/${kernel_version}-modules.tar.gz -C /media/rootfs/

returns:
tar: ./ti-linux-kernel-dev/deploy/4.10.0-28-generic-modules.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now

Any thoughts on how to overcome this issue?


BeagleBone Blue Getting Started
#2

Hi James,

sudo cp -v ./ti-linux-kernel-dev/deploy/{kernel_version}.zImage /media/rootfs/boot/vmlinuz-{kernel_version}

returns:
cp: cannot stat ‘./ti-linux-kernel-dev/deploy/4.10.0-28-generic.zImage’: No such file or directory

This means you didn’t properly set the “kernel_version” variable.

In the directions we state to read what the script dumped and then export that:

-----------------------------
Script Complete
eewiki.net: [user@localhost:~$ export kernel_version=4.X.Y-Z]
-----------------------------

So you’d type:

export kernel_version=4.X.Y-Z

Of course, replace the “X.Y-Z” with what the script actually dumped.

PS, if you’ve long cleared your terminal log, you can also look at the file “kernel_version” in the base directory of the repo, this is set at the same moment the script dumps the value…

$ cat kernel_version 
4.14.15-ti-r29

Regards,


#3

Robert,
I used the following to determine the “kernel_version”:
jcarroll@jcarroll-ThinkPad-X61-Tablet:~$ uname -r
4.10.0-28-generic

Based on this, I used the following command to set the “kernel_version” variable:
jcarroll@jcarroll-ThinkPad-X61-Tablet:~$ export kernel_version=4.10.0-28-generic

Is there an error in my procedure?

Best


#4

Hi James,

You’ve correctly determined the “kernel” your pc is running on.

However you are building a kernel for the BeagleBone Blue, with the “ti-linux-kernel-dev” script.

Totally Different Kernel’s…

Re-Read that section of the documentation. The point of setting “kernel_version” is so when you manually copy the zImage/modules/dtb’s you actually copy the ones you just built.

Regards,