Cannot export to pdf

I have tried the latest versions of Chrome and Safari on Mac. The export dialog stays up for a while after clicking the export button, then nothing. Usually a download animation happens and the file is downloaded. Not this time… Can you help?

I was doing a lot of exports on Wednesday (both Chrome & Edge under Windows) and I found the downloads were taking a much longer time than normal to start. Also if I didn’t wait for the download the export seemed to get canceled.

I just tried again this morning and it seems to be taking even longer than Wednesday, 40 seconds for the download to start.

Try waiting a full minute after clicking export to see if it is just slow.


I have submitted for this issue to be reviewed. I will update you as soon as they reply about a solution.
Sorry for the inconvenience.

Irfan, any update ?

Hello Pmageau,

I have not received any feedback yet. I have resubmitted the inquiry. Are you still having this issue?

Hello @pmageau, The Scheme-it team found and fixed an issue with the PDF export process. Due to your project size you may not be able to export the entire project as a single PDF, although, exporting each page individually should now work.

I just tried and it’s working normal again on my small single page schematic (<15 seconds vs. > 30 seconds).