Cora Z7 not recognised by PC

I’m a student and have to work with a cora z7 single core.
I am using vivado and vivado SDK but my card can not connect. (the red led is on)
I tried using adept 2 but my card isnt recognised by that as well
My breakers are set correctly (*confirmed with multiple collegues and my teacher )
The red light is on. I tried multiple usb cables (the same I use to programm my arduino and they work fine)
tried looking online but couldn’t find a suitable solution.
Thanks for your help!

Hi @random_bit , looking at:

https://reference.digilentinc.com/reference/programmable-logic/cora-z7/reference-manual

Make sure JP2 is in JTAG mode, also try another USB cable/hub.

Is this a brand new board, or has it been used in Class Previously?

Regards,

it’s brand new, I also got a friend to lend me his board. I tried multiple cables and no luck

Just to clarify, your friends boards works? with JP2 in JTAG mode?

A quick update, if it only occurs on your PC, Digilent has a recommend FTDI driver here:

Regards,

her board worked for her, jp2 is in jtag for both cards, i think the issue is from my pc but i installed the FTDI driver and still nothing is detected by vivado