Infineon Power Management Dev Board Issues

Hi -

I’ve ordered from digikey a power management IC development board: 448-EVALPS5401INTTOBO1-ND – manufactured by Infineon (“rocky” R2 DB296) – and I can’t get communication with PC using their I2C dongle!

I did alot of troubleshooting, and communicated to digikey, and they shipped a replacement board – same issue!! I think the board is ok, the problem is with the dongle/ Infineon powIR software.

Ok more detailed description:
The dongle is a USB to I2C that terminates in a 3-wire cable that connects to the board – ground, data, and clock. Reading the enclosed documents, after installing the PowIR software, and plugging in the USB dongle, a green “Connected” Icon should show up. This does show up, however the version comes up blank: USBxxxX FW: v0.0 . This is not correct. The supplied manuals (pdf) indicate USB005 should appear. I did install with admin privileges as recommended, and USBExpress driver is installed. When I scan the I2C bus from the software, with the I2C connector hooked to my logic analyzer, there are no signals detected (clock or data). I tried 2 different computers one with windows 10 and one with windows 7. Reading the data sheet and app notes, I bit banged an I2C protocol with a C8051F410 uController – I can successfully communicate with the board reading back the manufacturer ID/acknowledgements and visualizing on logic analyzer. Thus, it appears the USB dongle malfunctions but the DB296 Rocky R2 board is ok.

I tried contacting Infineon directly, but they won’t reply to my emails. Thanks anyone in advance for help/ideas!

See attached slides for more details.

Infineon_v2.pdf (540.1 KB)

Hi Scott,

Sounds like you may well have a defective dongle. However, before we go down that path, it would be worth making sure that it isn’t the USB cable that is the problem. You’d be surprised how often that ends up being the issue with development tools. Could you try with a different cable, or if possible, plug the dongle itself directly into your PC?

Also, I don’t have one in hand so I can’t see clearly, but is it possible to test continuity of the 3-pin cable?


Thanks for taking the time to reply.

I should have mentioned, I have used the USB cable to program a Digilent Cora board with Vivado successfully, and just in case, did try a different cable anyway - to no avail. In addition, Digikey sent me a replacement board AND dongle, both Dongles show the same behaviour! I’ve tried both dongles on two different computers (Win 7 and Win 10).

“plug the dongle itself directly into the PC” – not sure what you mean by this; one end plugs into the PC (USB port) other end is 3 wire I2C (gnd, clock, data).

The dongle is in a protective case, I’d have to crack it open to test continuity; might be worth a shot at this point, but I would think unlikely to get bad continuity in 2 separate dongles!!

Many thanks,


Hi Scott,

Did you happen to find and go through the Appnote AN-0035 that I just ran across? There’s some troubleshooting advice in there. In particular, starting on page 43.

Oh-my-gosh! That’s exactly what I see:

“If the left-most cell is green, but the middle cell reads “HW: USBxxxX” and the right cell reads “FW: 0.0”, this means the USBXpress Driver has installed correctly, but you do not have the right driver version in your IR PowIRCenter folder”"

I think you cracked the case! I’ll try this as soon as I get home.

I did have this Ap Note but missed this section. Many thanks, very excited, I’ve been trying to resolve this for days!

Hi Scott,

I was referring to using the USB-A plug on the dongle rather than using the extension cable, but I think you have that covered. Agree that the 3-wire cable is highly unlikely to be bad on two different units.

It really sounds like a driver/dll issue. I’m hoping you haven’t yet gone through AN-0035 troubleshooting steps, as that seems likely to be useful.

Yes I had missed this, you found the exact case I see, I’ll try ASAP when I get home THANKS, THANKS THANKS!!

Don’t thank me until it works.

David - yep you got it. THANKS, THANKS, THANKS! Was going nuts over this. NUTS!! Sometimes, one little thing messes up the works! You are awesome!

Glad to help!