RTC DS3231 issues on Arduino Nano

Hey there, I have bought 2 RTC modules from DigiKey, and both seem to not be working. I have tried 3 different Arduino Nanos, and they work for a bit. Then they don’t, any ideas?


Several DS3231-based modules/expansion boards exist, to which specifically are you referring?

It would be helpful if you could provide further details about the symptoms and any diagnostic measures taken. When saying they “don’t work” what exactly does that mean? That it stops responding to valid communications? That returned data is incorrect? Something else? Are you monitoring the interface bus directly, or simply observing behaviors via the development boards? What’s the status of the backup power source?

From what’s been mentioned, the behavior appears consistent across varying hardware samples. That’s often a good indication that the hardware is working as designed, but there’s some problem with one’s software or process.

1 Like

Hi Rick! Thanks for the email.

I probably should’ve specified in a few things.
So I will do that now.

I’ve connected the Adafruit DS3231 RTC (Breakout) Version module to proper pins, and ran the example code that Adafruit provides called “RTCLib” and it displays the proper data in the serial monitor (And on my I2C OLED display) it displayed the time, date and temperature correctly, as it should. Then after a few mins of running it, it just ends up “freezing” and doesn’t update anymore. (so I suppose thats It doesn’t respond to valid communications)

Then, if I just turn everything off for the night after hours of trying to get it working again, does the same thing. Again, works for a bit, then “Freezes” I do not have the battery plugged into the back of it, as apperently I don’t need a battery. (according the Google, and multiple sites, it’s just for back up in case main power source dies)

I also disconnected everything from bread board, and tried it with just the DS3231 RTC module instead of having the OLED as well. And nothing would appear, I2C Scanner wouldn’t even pick it up even though the scanner picked it up before. Nothing would show up in serial monitor as well if I Ran the RTCLib from Adafruit.

I’ve ordered new Nanos, and 5 new RTC modules (The none breakout version) to see if the other versions is more successful. Will be here today thankfully.

I think it will be wise to measure the voltage of the coin cell battery with a digital multimeter. If the CR1220 is dead, the board is very likely to behave abnormally.

Eh, I got new Ds3231, RTC modules. Everything is working now perfectly so problem solved-ish

Good to know that it’s working. By the way, if you ever wish, you can make a DS3231 module by yourself. Here is a tutorial about how to make a DS3231 RTC module.