Doubt with xBee S2c with firmware 9000 o 9002

Well, the first thing is that I was glad to find this forum as it can answer many questions, so congratulations for this forum to all users and Staff.

Before moving on to the 9000 or 9002 (DigiMesh 2.4 TH) version of xBee S2C I used the 4060 (ZIGBEE YH Reg), with this version I could do that only by putting the same number in ID both in the coordinator and in the Routers they connected I perfectly connected to the Coordinator without problem, now using the new function (DigiMesh 2.4 TH) version 9000 or 9002 I do not get it.

Surely I do something wrong, so if any of the users know how I can do it, it will do me a great favor.

Many thanks.

Regards.

Bueno, lo primero es que me a alegrado encontrar este foro ya que me puede resolver muchas dudas, a si pues enhorabuena por este foro a todos los usuarios y al Staff.

Antes de pasarme a la versión 9000 o 9002 (DigiMesh 2.4 TH) de xBee S2C utilizaba la 4060 (ZIGBEE YH Reg), con esta versión podia hacer que solo con poner el mismo numero en ID tanto en el coordinador como en los Routers se conectaban perfectament se conectaba al Coordinador sin problema, ahora utilizando la nueva función (DigiMesh 2.4 TH) versión 9000 o 9002 no lo consigo.

Seguro que algo hago mal, a si que si alguno de los usuarios sabe como puedo hacerlo me hará un gran favor.

Muchísimas gracias.

Saludos.

Hello Lacoma,

I was speaking to my engineer who works with this technology and if you are changing from Zigbee to the DigiMesh there will be some changes to your system. Here is a link to the DigiMesh User Manual.

If you don’t mind me asking, any specific reason you are changing from Zigbee to DigiMesh?
-Robert

Of course you can ask, it’s not that it has changed, the new xBee come with this technology, and I can’t change the firmware since it gives me an error.
So when I connect them to XCTU, it already comes out with DigiMesh 2.4 TH, as I say I have tried to put the previous firmware, but it does not let me change it.

I liked Zigbee more because, as I was saying, if I get a sensor that I have to check, I can’t connect to it since the sensor Router sensor points to the coordinator at “Destination Adress Low”, otherwise with Zigbee just to change My coordinator’s “Network ID” could already see if it was broadcasting.

Anyway, if DigiMesh doesn’t support this function, I can’t do anything, a shame.

Thank you very much for your help Robert.

Regards.

Hello Lacoma,
DigiMesh modules do not communicate with Zigbee modules so you will need to change the firmware on the DigiMesh module to Zigbee. Have you tried the Firmware Recovery tool in XCTU to try changing the firmware? Instructions start on page 156 of the XCTU User Guide. Are you using one of the Digi International XBIB-U-DEV development boards with XCTU when trying to change firmware?
Regards,
Scott

2 Likes

Of course, it is the one I use to combine XCTU firmware, what I don’t know is that they had a development board, the truth is that I used a generic one, anyway I will try again with the manual that has happened to see if There is luck.

Thank you very much Robert.