Esp32 s3 boc lite needs reset

Hi. We recently bought 2 esp32 s3 Box lites, and im trying to port some code that we had running on arduino boards. We have a presentation in 2 weeks which could result in big orders.

Anyway, i seem to have screwed it upbtesting some code and need to do a factory reset. I can still see the board in the ide but cant download anything. Ive tried a couple of esp tools to dowload firmware and bootloader but nothing seems to complete.

Can you advise how i get this back to as it was when it was shipped



Hello Phil,

That’s not good!

I have yet to use that particular device, but it’s now on my list for useful and fun technology.

Let me give you a few ideas and we can hope that others are able to provide a more detailed answer:

  1. I’m sure you have already seen this, but just in case, be sure to look at:
  1. If you haven’t already done so, post this question to adafruit industries - Forums Index. Adafruit states that they will provide support for their product even if you purchased it from DigiKey.

Sorry I couldn’t help your directly. I do hope that another community member is able to provide a few pointers.

Please keep us informed. I’m curious about how you integrated this user interface into your project.

Best Wishes,


Hi APDahlen, thanks so much for replying.

Yes ive been through that process, but i get the following;

Uploading stub...
Running stub...
Stub running...
Changing baud rate to 115200
No serial data received.
[2023-09-27 15:27:23,434][ESP8266Loader_spi[1]][][line:750][ERROR]: ESP32S3 Chip stub error esp_stub_and_set_baud.
no log file output ...

Also used a ESPtools web based system with similar results.

Cant help feeling i need to do something at quite a low level.


That’s what I thought, but I included the link just in case and for others who may encounter a similar problem.

Any response from Adafruit?



1 Like


Someone from ESP replied and suggested the following;

Please use ESP-Launchpad … ecommended to quickly flash the factory firmware, please choose the following file:

If download fails, please hold down the Boot button and then press the Reset button to initiate Firmware Download mode manually.

BUT when I try this it appears that my device thinks it’s paired with something – so won’t do the Flashing.

Waiting for further response.

NO nothing from Arduino Forums yet.


Phil Jones

1 Like

I’ve been advised to do a hard reset by pressing the Boot and Reset buttons - but not sure in which order or how long for. Presume they must be done with it plugged in. I have tried various combinations but doesn’t seem to make a difference.


I found the below from Adafruit. Please take a look to see if it’s information assist you.
Factory Reset | Adafruit ESP32-S3 TFT Feather | Adafruit Learning System


Nathan you are a life saver - thank you so much.

Used that ESP Tools as it said - but never worked, so went back to the beginning and did the Factory Reset Firmware UF2 - which seemed to work. I then ran the ESPTools again but downloaded the ESP-BOX-Lite_Demo .bin file that I’d got a few days ago - and BINGO - the device is now back as it was to start with.

Thank you so much.


See the recent 2 posts in that thread. I have now got the device back as it was, thanks to someone called Nathan.


Phil Jones


I’m so glad @Nathan_2268 saved your timeline.

Have a good weekend.