Filter is not working

Hi, I try to find components on you website using filter. I does not work, I cannot select anything. I have try using IPAD, Android Phone it also did not work.

Thank
C.S.

1 Like

Welcome to the Digi-Key Technical Forum. I know out website can be a challenge. The only thing I can say is when you are searching for products, sometimes people click to many paramters and lose the results. For myself when I get in a catagory, I start and choose the most important thing and apply filters. I only do one box at a time. This way you get results and the list gets smaller each time. By doing the options only in one box that is the most important first that will narrow options . Then I just go onto the next one. I know I have been guilty and did multiple boxes and choose different paramters. I lose everything. Though now we have the gray out function. That will eliminate options also. My recommendation is to only do one box at a time. Apply filters each time. This narrows down the search until you get something that would be useable.

Now it is different if you are unable to do anything on the webite at all . Now that I would say to go to the right hand side where it states feedback. Click on there is you are having issues with the website at all. This would get directed to someone who can help .

Thank, I’ll send it through Feedback. Never got this issue before.
C.S.

I also have the same problem, I can not click anything on the filter, even I can not click the feedback button. I am using firefox 103.0.2 (64-bit). I have tried to clear cookies and disable tracking, but to no avail.

Thanks.

I have the same issue. Tried Firefox versions 50.1, 60, 69, and 91.11, with completely fresh profiles (no cookies or extensions or other junk). Tried Chrome. Tried Brave. Filters no work. Can’t even click Feedback. Please help.

I change ISP from my home ISP to mobile phone ISP, one of the company works another one has the same issue.