Website part selection filters are not working

Hi Digikey, the website part selection filters are not working. I was trying to select a SMD LED and I selected various filters and applied them and the available parts parts did not change. For example selecting color= Red and and applying the filter and all the other colors still show up in the list of available parts.

Hello @crherrin,

I was not able to duplicate the issue you are having. Can you tell me which browser you are using and share a link to the page you are on so I can forward the information to our web team to look into it. In the meantime I would suggest the standard clearing of cookies and closing and restarting your browser.


Hi Robert,
I was looking for an LED and I was using the following web link
The normal use is to select
In stock
Normally Stocked
RoHS Compliant
Marketplace Product Exclude
Click Apply All
then select color Red
Apply All

The first LED in the list is color Green

I tried this in Chrome and Edge, neither worked.

I cleared all the cookies for all sites with the domain ,digikey,com (I put comas because of only 2 links rule) and restarted the chrome browser.
Filters still did not work.
I even added "[
,]digikey,com" (I put comas because of only 2 links rule) to the “Sites that can always use cookies” section of chrome.
Filters still did not work.

I will try resetting chrome to defaults and report back.

Thanks Craig

I just tried that link and had the same experience. I have forwarded it to members of the web and search team to see if I can get any help. It is Friday evening so it may take a bit to get an answer. As soon as I here back I will let you know.

1 Like

I tryed reseting Chrome to defaults which disables all extentions and it still did not work.

+1 here, having the same issue.

Also having same issue pretty much across the board for all searches. Also on Edge and Firefox.

When I select the filters it appears to show the correct number where it says “xyz remaining” but applying doesn’t actually filter.

Same issue here. Trying to look for capacitors, half the time I get a 404 trying to navigate to the ceramic capacitors page. If I get there part filtering doesn’t work. I’ve cleared cookies, etc.

In terms of some further debugging, loooking at the api calls, there’s a bunch of redirects. When I click a filter, I see:

GET /products/api/v2/product-count/60 → 307 redirect
GET /api/v2/product-count/60 → 301 redirect to API Solutions | DigiKey
GET API Solutions | DigiKey

So, to me it looks like your website isn’t an authorized user of your API or something.