IMX6q Sabre Board for Smart Devices - sdcard installation issues


#1

Hi,

I have basic SabreSD Board, and I followed the instructions here and have some issues:

 [Sabre Board](https://eewiki.net/display/linuxonarm/i.MX6q+SABRE+Board+for+Smart+Devices)

I have a Ubuntu 14.04 LTS (updated to latest) as a guestOS inside
VMWorkstation Pro 12 with util-linux == 2.20.1

I performed all of the steps and tried the SDCard in my system.
and put sdcard into my sabre board. Upon power-up - there was no output at all
(no u-boot or any console output)

I am not sure I understand the sfdisk scripts. When executed - it only created
a single ext4 partition?

I then found a version of imx Linux user guide and followed those instructions in
constructing the sdflash partitioning:

[imx6 linux user guide](https://community.nxp.com/servlet/JiveServlet/download/571486-1-362556/i.MX_Linux_User's_Guide.pdf)

After manually doing this - and install the built u-boot.imx and copying the zImage and
dtbs to the first partition (starting @ 20480), and install the rootfs in the second ext4
partition (as well as following the eewikii installation instructions). -

This succeeded in booting - but I have some issues with no output to the HDMI.

I am wondering what are the issues with subject line instructions for my setup?

Thanks in advance!

Tom


#2

Update:

Using a manual process - I created a single ext4 partition
and that worked too.

So, it was just the sfdisk utils that are mal-configured
(and that it isn’t outputting HDMI)


#3

Hi Tom,

We’ve been fighting sdcard mis-writes caused by Virtualization software (VMware/VirtualBox/etc) for a long time. A native install of 14.04 would probably create the sdcard correctly. (Although i only test Ubuntu 16.04 and Debian Stretch at this point in time).

Just finished testing v4.1.x & v4.4.x, video is broken, even when trying to force it via: [video=HDMI-A-1:1024x768@60e]

As v4.9.x will need a few changes (just like Wandboard) for the mmc card node name, i’m working updating u-boot right now.

Regards,


#4

I’ve updated u-boot to v2017.01 and added v4.9.x, video still doesn’t work, but we are getting hints now:

[    5.718584] [drm] forcing HDMI-A-1 connector ON
[    5.723555] imx-drm display-subsystem: bound 120000.hdmi (ops dw_hdmi_imx_ops)
[    5.738419] imx-drm display-subsystem: failed to bind 2000000.aips-bus:ldb@020e0008 (ops imx_ldb_ops): -517
[    5.748477] imx-drm display-subsystem: master bind failed: -517

Regards,


#5

awesome - fyi - the u-boot is outputting correctly to the HDMI - so that is a good thing!

also, when you say added v4.9 - you mean the linux from armv7-multiplatform?


#6

Correct, v4.9.x branch from armv7-multiplatform

PS, when you boot with the newer u-boot and v4.9.x make sure it’s passing root=PARTUUID=something-01 as this works around the mmc node number change in v4.5+…

Running uname_boot ...
Using: mmcroot=PARTUUID=0749dc41-01 ro ...
loading /boot/vmlinuz-4.9.7-armv7-x4 ...
6385856 bytes read in 388 ms (15.7 MiB/s)
loading /boot/dtbs/4.9.7-armv7-x4/imx6q-sabresd.dtb ...
51594 bytes read in 354 ms (141.6 KiB/s)
debug: [console=ttymxc0,115200 root=PARTUUID=0749dc41-01 ro rootfstype=ext4 rootwait] ...
debug: [bootz 0x12000000 - 0x18000000] ...
Kernel image @ 0x12000000 [ 0x000000 - 0x6170c0 ]
## Flattened Device Tree blob at 18000000
   Booting using the fdt blob at 0x18000000
   Using Device Tree in place at 18000000, end 1800f989

Starting kernel ...

Regards,


#7

I am not following you here (I’m pretty much a newbie with this build system).
normally I have something like: “mmcroot=/dev/mmcblk2p2 ro

are you saying that it should be something like: “mmcroot=PARTUUID=123456cc-01 ro” ?
does it matter what the “something” is (in the above ‘123456cc’ ) ?


#8

It’s your choice:

Anything before v4.5.x, you can use:

mmcroot=/dev/mmcblk0p1 ro

But on this platform after v4.5.3:

mmcroot=/dev/mmcblk2p1 ro

Here’s one of my previous write up’s on this issue: V4.5.x+ mmc re-numbering changes

By using mmcroot=PARTUUID=123456cc-01 ro (which u-boot detects the 123456cc-01 part) you don’t have to worry about random mmc node name changes…

Regards,


#9

BTW, Just tested v4.10.x-rcX, hdmi is busted there. (Ethernet is actually busted on my board too…)

Regards,


#10

I need to prove that I can run ubuntu on base sabresd board and get some type of video out to prove
it can be done -and that I can add packages to it. Is there some type of kludge to get this to work?

t


#11

So the kludge is, to just add: cmdline=video=HDMI-A-1:1024x768@60e to /boot/uEnv.txt

root@arm:~# cat /boot/uEnv.txt 
uname_r=4.10.0-rc6-armv7-x1
cmdline=video=HDMI-A-1:1024x768@60e

However even that’s not working for me.

According to parse-edid, my monitor is detected, so ^ kludge isn’t required, but the hdmi isn’t coming up…

root@arm:~# cat /sys/class/drm/card1-HDMI-A-1/edid | parse-edid
Checksum Correct

Section "Monitor"
	Identifier "DELL 1707FP"
	ModelName "DELL 1707FP"
	VendorName "DEL"
	# Monitor Manufactured week 48 of 2006
	# EDID version 1.3
	# Digital Display
	DisplaySize 340 270
	Gamma 2.20
	Option "DPMS" "true"
	Horizsync 30-81
	VertRefresh 56-76
	# Maximum pixel clock is 140MHz
	#Not giving standard mode: 1152x864, 75Hz
	#Not giving standard mode: 1280x1024, 60Hz
	Modeline 	"Mode 0" +hsync +vsync 
EndSection

Something regressed on this board. (also just tested mainline imxv6v7 & multiv7 defconfig’s)

Regards,


#12

when you say ‘board’ your physical board or the BSP package?


#13

Hi Tom,

By board i mean the physical board.

Just tested v3.19.x < thru > v3.15.x no hdmi video.

Regards,


#14

I tested on my brand new board with your solution - and still no hdmi video?
This is a bummer!

Best Regards


#15

Hi Robert

I re-ran my configuration Linux version 4.10.0-rc6-armv7-x1. It looks
like I had another issue that was causing no HDMI output.

I fixed that issue - and I now have output to HDMI…Yeah!

But, it is blank screen…

Looking at the console output, it seems to have an error here:

[ TIME ] Timed out waiting for device dev-mmcblk2p1\xc2\xa0.device.
[DEPEND] Dependency failed for / .
[DEPEND] Dependency failed for Local File Systems.

Any thoughts?

tom