Nimbelink cape lite for beaglebone issue


#1

hello

I’ve got a nimbelink beaglebone cape lite (with a nimbelink NL-SW-LTE-S7648 cell module) plugged into a
beaglebone green. Nothing else is connected. I SSH into the beaglebone and try to communicate with the
module using AT cmds via minicom but no response. I had this working 6 months ago but with a different module - NL-SW-GPRS.
I accidently damaged the module so I decided to switch the more recent NL-SW-LTE-S7648.

I checked to see if the device tree overlay was loaded (dmesg | grep NL-AB-BBCL) but I’m not sure if actually
is. The message I get is different than the cape lite manual shows. I get -

[0.00]Kernel command line: console=ttyO0, 115200n8 bone_capemgr.uboot_capemgr_enabled=1 root/dev/mmcblk0p1 ro
rootfstype=ext4 rootwait uboot_detected_capes=NL-AB-BBCL, coherent_pool=1M net.ifnames=0 quiet

I re-install the overlays =>
sudo apt update
sudo apt install bb-cape-overlays

Nothing changes.

UART4 is enabled in the uEnv.txt.

Any help will be greatly appreciated.

thanks toyo


#2

@toyose, that’s showing it loaded properly…

On these newer modem’s the usb interface is enabled, have you tried connecting a usb cable from the cape to the board? you should see a new usb interface show up.

https://elinux.org/Nimbelink:NL-AB-BBCL

Regards,


#3

hi Robert

Thanks for your reply.
I tried that as well. Connecting the usb through beaglebone did not work.
Connecting directly windows, Ubuntu or debian did not detect the USB.
It looks as if the cell module is damaged I dont know anyway to determine this?


#4

@toyose, thru the uart, does the device respond to AT commands, such as:

AT+KGPIO=10,1 //Turn on D1 LED
AT+KGPIO=10,0 //Turn off D1 LED

Regards,


#5

The cape is set up to communicate via uart4. So I ssh into beaglebone and configure
uart4 to 115200, 8, 1, no flow control.
I never actually tried using usb before until you mentioned it.

So to answer your question, I’m not even getting the simple AT cmd to work. No led indication
of the status of the module, no power led. I dont even know how to begin to
troubleshoot it.


#6

@toyose,

Just got a working cape/modem in the lab this morning, can you dump the configuration of your beagle:

debian@beaglebone:~$ sudo /opt/scripts/tools/version.sh 
git:/opt/scripts/:[e9bcff232834702c1c810710706ee815d77b080b]
eeprom:[A335BNLT00C03318BBBK1BC9]
model:[TI_AM335x_BeagleBone_Black]
dogtag:[BeagleBoard.org Debian Image 2018-11-25]
bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.09-00002-gd5b4c4b656]:[location: dd MBR]
kernel:[4.14.79-ti-r84]
nodejs:[v6.14.4]
uboot_overlay_options:[enable_uboot_overlays=1]
uboot_overlay_options:[uboot_overlay_pru=/lib/firmware/AM335X-PRU-RPROC-4-14-TI-00A0.dtbo]
uboot_overlay_options:[enable_uboot_cape_universal=1]
pkg check: to individually upgrade run: [sudo apt install --only-upgrade <pkg>]
pkg:[bb-cape-overlays]:[4.4.20181120.0-0rcnee0~stretch+20181120]
pkg:[bb-wl18xx-firmware]:[1.20180517-0rcnee0~stretch+20180517]
pkg:[kmod]:[23-2rcnee1~stretch+20171005]
pkg:[librobotcontrol]:[1.0.4-git20181123.0-0rcnee0~stretch+20181124]
pkg:[firmware-ti-connectivity]:[20170823-1rcnee1~stretch+20180328]
groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c bluetooth netdev cloud9ide gpio pwm eqep admin spi tisdk weston-launch xenomai]
cmdline:[console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait uboot_detected_capes=NL-AB-BBCL, coherent_pool=1M net.ifnames=0 quiet]
dmesg | grep pinctrl-single
[    1.110666] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
dmesg | grep gpio-of-helper
[    1.122504] gpio-of-helper ocp:cape-universal: ready
END

How are you powering the device? Are you using the recommended 12V DC connector?
The modem i have here needs 921600, it’s responding to basic commands:

debian@beaglebone:~$ tio -b 921600 /dev/ttyO4
[tio 18:37:53] tio v1.26
[tio 18:37:53] Press ctrl-t q to quit
[tio 18:37:53] Connected

OK
AT
OK
AT+CESQ
+CESQ: 99,99,255,255,255,255

OK

Regards,


#7

tio @ 921600 still did not work.
My power supply is a 12v 2A XP Power adapter powered from the cape.