Pandaboard EA3


#1

Hello,

I’ve been recently given a pandaboard EA3 ( which is an Early access A3 board).

I was following the tutorial for the pandaboard here :
https://www.digikey.com/eewiki/display/linuxonarm/PandaBoard

All is working but well but I’m unable to make the wifi work.

I’ve tried

  • Changing many kernel configurations ( clean build everytime )
  • Loading the modules manually (mac80211, wlcore, wl12xx) with insmod

but the wlan interface won’t show up.

I used the kernel 4.19

I’ve tried using a prebuilt ubuntu 12.04 and everything is working fine.

I know its old hardware but I was just wondering if someone have had the same issue.

Best regards


#2

@MrMathMo, Sadly my EA3 Panda died a few years ago, so i don’t have it anymore. From what i remember, the early Panda’s (pre ES’s) need u-boot to properly setup one of the 32khz clocks…

Your not going to like this next part…

Back in v3.9.x era ( Jun 1, 2013 ) i did this change, which was “pre-dt”… Sadly that branch is pretty much bit-rotted…

But the 32khz clock is clue for today, make sure it’s set in both u-boot and the kernel.

Regards,


#3

Alright thank you for your time,

I don’t think I have enough knowledge to continue.
I’m really not that good at programming.
Unless, it’s a simple configuration changes.

I could port back the patches but I’m not sure if I have the time to do it or if it would even work.

I’ll keep on using the pre-built image.

I know there’s a CONFIG_OMAP_32K_TIMER setting in the kernel which I set to y.

I’m not really familiar with u-boot so I’ll keep investigating if there’s a config for that.

Thank you again :smile: