SAMA5D4 Xplained Ultra (RomBOOT)


#1

I followed the instructions on the eewiki to setup an SD card for debian. However, all I get is RomBOOT when I try to boot it from the SD Card.

I found a similar topic on this forum titled “Uboot SPL for sama5d3 xplained”, but I still get RomBOOT for my board.


#2

@bmiller59, off the top of my head, this can be caused by a couple issues on the sama5d4 xplained ultra board. What position are J7 and J8? Make sure they off. Next try triggering BP3/BP2 to see if it’ll fire up. Finally can i assume you are not using a VM to write to the SD card?

Sadly my board is at work, so I won’t be able to verify this till Monday.

Regards,


#3

Yes, No VM to write to SD card.

I made some progress. I modified the BOOT.BIN file as described in the “Uboot SPL for sama5d3 xplained” topic. with this command: dd bs=208 skip=1 if=boot.bin of=bootShort.bin

Now, it starts to boot up, but hangs at this point:

1.730000] ALSA device list:
[ 1.730000] No soundcards found.
[ 1.730000] atmel_usart fc00c000.serial: using dma0chan8 for rx DMA transfers
[ 1.740000] atmel_usart fc00c000.serial: using dma0chan9 for tx DMA transfers
[ 1.750000] Waiting for root device PARTUUID=520787dd-02…
[ 2.010000] random: fast init done
[ 3.760000] mmc0: problem reading SD Status register
[ 5.840000] mmc0: error -110 whilst initialising SD card
[ 8.000000] mmc0: problem reading SD Status register
[ 10.080000] mmc0: error -110 whilst initialising SD card
[ 12.240000] mmc0: problem reading SD Status register
[ 14.320000] mmc0: error -110 whilst initialising SD card
[ 16.480000] mmc0: problem reading SD Status register
[ 18.560000] mmc0: error -110 whilst initialising SD card

Not sure what to try next. Thanks


#4

@bmiller59, i was able to replicate this with another microSD, it looks like u-boot isn’t properly init’ing the mmc, i moved the directions back to AT91Bootstrap vs U-Boot SPL, and now that microSD works again:

https://www.digikey.com/eewiki/display/linuxonarm/SAMA5D4+Xplained+Ultra

debian@arm:~$ dmesg | grep SAMA
[    0.000000] OF: fdt: Machine model: Atmel SAMA5D4 Xplained
debian@arm:~$ uname -r
4.19.13-sama5-armv7-r1
debian@arm:~$ lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
mmcblk0     179:0    0  3.7G  0 disk 
├─mmcblk0p1 179:1    0   48M  0 part /boot/uboot
└─mmcblk0p2 179:2    0  3.7G  0 part /
AT91Bootstrap 3.8.10 (Tue Jan  8 09:36:10 CST 2019)

EEPROM: Loading AT24xx information ...
EEPROM: BoardName | [Revid] | VendorName

EEPROM: Using default information

EEPROM: Board sn: 0x1012420 revision: 0x680820

HDMI SiI9022: Enter D3 Cold mode
SD/MMC: Image: Read file u-boot.bin to 0x26f00000
SD: Card Capacity: High or Extended
SD: Specification Version 3.0X
SD: Not support hs function switch
SD/MMC: Done to load image
<debug_uart> 

U-Boot 2019.01-rc3-dirty (Jan 08 2019 - 09:36:49 -0600)

CPU: SAMA5D44
Crystal frequency:       12 MHz
CPU clock        :      600 MHz
Master clock     :      200 MHz
DRAM:  512 MiB
NAND:  atmel_nand: Fail to initialize #0 chip0 MiB
MMC:   Atmel mci: 0
Loading Environment from FAT... *** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   eth0: ethernet@f8020000
Press SPACE to abort autoboot in 3 seconds

Regards,


#5

Great!

Thank you for taking the time to look into this.


#6

I don’t think this is related to the original issue, but the boot process is stuck in a loop.

I’ve tried several sd-cards, and all three versions of the kernel.

Here’s what loops:

AT91Bootstrap 3.8.10 (Thu Jan 10 20:18:26 CST 2019)

EEPROM: Loading AT24xx information …
EEPROM: BoardName | [Revid] | VendorName

EEPROM: Using default information

EEPROM: Board sn: 0x1012420 revision: 0x680820

HDMI SiI9022: Enter D3 Cold mode
SD/MMC: Image: Read file u-boot.bin to 0x26f00000
SD: Card Capacity: High or Extended
SD: Specification Version 3.0X
SD/MMC: Done to load image
<debug_uart>

U-Boot 2019.01-rc3-dirty (Jan 10 2019 - 20:20:46 -0600)

CPU: SAMA5D44
Crystal frequency: 12 MHz
CPU clock : 600 MHz
Master clock : 200 MHz
DRAM: 512 MiB
NAND: BUG at drivers/mtd/nand/raw/nand_base.c:4357/nand_scan_tail()!
BUG!
resetting …
RomBOOT


#7

@bmiller59,

U-Boot 2019.01-rc3-dirty (Jan 10 2019 - 20:20:46 -0600)

CPU: SAMA5D44
Crystal frequency: 12 MHz
CPU clock : 600 MHz
Master clock : 200 MHz
DRAM: 512 MiB
NAND: BUG at drivers/mtd/nand/raw/nand_base.c:4357/nand_scan_tail()!
BUG!
resetting …
RomBOOT

actually that’s u-boot, looks like the nand driver is failing, wonder if we just disable nand in u-boot…

Regards,


#8

@bmiller59, give this patch a try to disable nand:

diff --git a/configs/sama5d4_xplained_mmc_defconfig b/configs/sama5d4_xplained_mmc_defconfig
index f39988e3ea..58d66f58f0 100644
--- a/configs/sama5d4_xplained_mmc_defconfig
+++ b/configs/sama5d4_xplained_mmc_defconfig
@@ -31,7 +31,7 @@ CONFIG_CMD_BOOTZ=y
 # CONFIG_CMD_FLASH is not set
 # CONFIG_CMD_LOADS is not set
 CONFIG_CMD_MMC=y
-CONFIG_CMD_NAND=y
+# CONFIG_CMD_NAND is not set
 CONFIG_CMD_SF=y
 CONFIG_CMD_USB=y
 CONFIG_CMD_DHCP=y
@@ -56,8 +56,8 @@ CONFIG_SYS_I2C_AT91=y
 CONFIG_I2C_EEPROM=y
 CONFIG_DM_MMC=y
 CONFIG_GENERIC_ATMEL_MCI=y
-CONFIG_NAND=y
-CONFIG_NAND_ATMEL=y
+# CONFIG_NAND is not set
+# CONFIG_NAND_ATMEL is not set
 CONFIG_DM_SPI_FLASH=y
 CONFIG_SPI_FLASH=y
 CONFIG_SPI_FLASH_ATMEL=y

U-Boot will now bypass nand…

RomBOOT


AT91Bootstrap 3.8.10 (Fri Jan 11 12:52:25 CST 2019)

EEPROM: Loading AT24xx information ...
EEPROM: BoardName | [Revid] | VendorName

EEPROM: Using default information

EEPROM: Board sn: 0x1012420 revision: 0x680820

HDMI SiI9022: Enter D3 Cold mode
SD/MMC: Image: Read file u-boot.bin to 0x26f00000
SD: Card Capacity: High or Extended
SD: Specification Version 3.0X
SD: Not support hs function switch
SD/MMC: Done to load image
<debug_uart> 

U-Boot 2019.01-rc3-00001-gf2cb6d139b-dirty (Jan 11 2019 - 12:50:49 -0600)

CPU: SAMA5D44
Crystal frequency:       12 MHz
CPU clock        :      600 MHz
Master clock     :      200 MHz
DRAM:  512 MiB
MMC:   Atmel mci: 0
Loading Environment from FAT... *** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   eth0: ethernet@f8020000
Press SPACE to abort autoboot in 3 seconds
=>

Regards,