STM32MP157C-DK2 Wlan0: Unsupported driver 'nl80211'

Mehdi - Copy.txt (117.8 KB) MehdiKernel - Copy.txt (97.3 KB)

I am working with Buildroot, to flash an image on my STM32MP157C-DK2 I wanted to have Wi-Fi working it but I got this error:

Code:

Successfully initialized wpa_supplicant

nl80211: 'nl80211' generic netlink not found

Failed to initialize driver 'nl80211'

wlan0: Unsupported driver 'nl80211'

FAIL

I configure the interfaces and wpa_supplicant.conf files correctly normally. I don’t know wthat that means but my configuration in the menuconfig and linux-menuconfig is right (I think). Does it maybe have something to do with my target machine (the STM in this case) ?

Every Kind of Help is appreciated since I am a newby in Embedded Linux

p.s I don’t know why but it seems like the Wifi Bluetooth Card is Murata-LBEE5KL1DX-883. Maybe my Kernel configuration does not support it

That’s odd, do you have the wifi driver enabled (kernel .config)? Never mind, i see you attached the .config…

After reviewing your config, why don’t you have “CONFIG_BRCMFMAC” enabled that’s for the WiFi Chipset…

Regards,

That may be it otherwise I don’t see anything else related… Everything is setup correctly
But where do I enable CONFIG_BRCMFMAC ? is it in the kernel configuration or in the system configuration?

kernel config.

Regards,

can you tell me where exactly ? Like the Konfig is really huge

Under which section can I find it ?

Menuconfig has a simple search, with this keyboard key: “/”

Regards,

Okay thanks for the tipp :smiley:

I’ll let the compile run and I’ll hit you up if there is something new

Still does not help … I get the same error

this link may help but I didn’t understand how to install the firmware:http://lists.busybox.net/pipermail/buildroot/2020-November/295607.html

when I lshw I get

lshw -class network
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: eth0
       serial: 00:80:e1:42:6b:16
       size: 1Gbit/s
       capacity: 1Gbit/s
       capabilities: ethernet physical tp aui bnc mii fibre 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=st_gmac driverversion=Jan_2016 duplex=full ip=192.168.8.15 link=yes multicast=yes port=MII speed=1Gbit/s

My Kernel configuration is correct … I don’t know what’s going wrong here
I can share the files that I modified[.config.txt|attachment].config.txt (98.6 KB)
.configSystem.txt (116.3 KB)interfaces.txt (432 Bytes) wpa_supplicant.conf.txt (171 Bytes)

Well, it looks like Buildroot doesn’t have full support for this board yet.

Looking at Buildroot’s git repo: https://github.com/buildroot/buildroot/blob/master/README

You will need to follow this guide when submit patches to that organization:

ST’s development repo can be found here: https://github.com/STMicroelectronics/meta-st-stm32mp/tree/dunfell/recipes-kernel

Regards,

I was told that a Wi-Fi patch is available. Like I said I am not aware till now on how I am supposed to do to implement the patch but I will check the links you provided.

It’s actually more then just that patch… I can get the WiFi to init in 5.8.x in my kenrel tree, but it still doesn’t fully work:

Regards,

Well at least it initilizes in your case. If you have some news please contact me either here or through e-mail : ge37vok@mytum.de

I am using kernel 4.19 … bit old compared to the one from Yocto for example and it does not support complex features like WiFi easily.