Hello guys,

I’m testing a T9602 sensor using Controllino MAXI. I hooked up the connections and uploaded the code, the results are:

  • Humidity measurements respond successfully and accurately.
  • Temperature readings don’t respond (stuck at -39.77).
    I doubted the code, therefore I tried another code and library, same results!
    I suspect either the sensor doesn’t send a complete measurement cycle or I’ve got a faulty sensor.
    I appreciate your advices and suggestions.

Hello @Wael,
Have you tried the T9602 library at https://github.com/NorthernWidget-Skunkworks/T9602_Library ? I have used successfully in the past.

Hello @ScottRaeker, thanks a lot for your response.
I’ve actually used the library you’ve mentioned and got the same result!
Is there a way to check the sensor’s functionality and ensure it actually takes the temperature measurements?

Hello @Wael,
Have you looked at the raw i2c temperature data to see if its changing? There are some status bits for valid data you can check as referenced on page 23 (Table 9) of https://www.amphenol-sensors.com/hubfs/Product%20Documents/AAS-916-127J-Telaire-ChipCap2-022118-web.pdf .When I used the library I modified slightly to read 4 bytes (project at Machinechat with ESP8266 and Amphenol T9602 sensor ). The sensor may be faulty, I assume you don’t have any others to test?