Wandboard Quad Wi-Fi issues after soft reboot


#1

Hello,

After some years, I have started using again my Wandboard Quad (rev. B1) and installed ArchLinux ARM. Everything is working properly, even Wi-Fi after installing the proper txt files, but after a soft reboot the wireless interface is lost.

I have to do a hard reset, i.e. issue poweroff and then press the reset hardware button, in order to make the interface available again.

Is there any workaround for that which does not require physical access?

I have also tried building the 4.14 and 4.19 kernels as suggested in eewiki, but unfortunately the interface was not appearing there, too.


#2

@joko, does it help if you lengthen the delay here:

We really need to fix the wifi setup on the wand’s, our rfkill driver doesn’t work on the newer rev d’s.

Regards,


#3

@RobertCNelson I have tried to set this up to 110, but unfortunately it did not work :frowning: Is there anything else I can do?


#4

@joko, thanks for testing. We will have to figure out another way to reset the wifi module. Might be best to soft reset it in u-boot.

Regards,


#5

@RobertCNelson, is there a way to soft reset in u-boot in an automated way, i.e. after issuing reboot in Linux and without serial access?


#6

Hi joko, I tried the reboot in Linux way, but that seems to not work too. Did you get any way around till now?

Regards,
Smith https://dltutuapp.com/tutuapp-download/
https://showbox.run/


#7

@yamapaxu, it’s the wifi module that ends up a in a weird state, we need to patch u-boot, to auto-reset this module on startup.

Regards,


#8

@yamapaxu, unfortunately I have still not found any workaround. I will try to report here if I find anything.

@RobertCNelson, let me know if you have any patch I could try to reset the Wi-Fi module at U-Boot.


#9

Sorry, I currently do not have anything to test at this point in time. I also waiting for a response back from the WandBoard developers such that we can figure out the WiFi/Bluetooth on the RevD’s…

Regards,