404 Error returned in all BarCoding APIs

I have a fairly simple API script that I have been using to pull specific part data from the ProductDetails API and it has been a life saver.
I recently tried to use the Barcoding set of APIs to pull traceability (lot/date codes) from the packing slips. However, the resource url posted on the API info page:
Returns a 404 error, even when trying to run from the site.
This happens with all the barcoding APIs: ProductBarcodes, Product2DBarcodes, PackListBarcodes, and PackList2DBarcodes.
If I take any of those APIs, and plug it in the URL and put it in my browser, I get no service response:

{“fault”:{“faultstring”:“Unable to identify proxy for host: secure and url: /BarCoding/v3/ProductBarcodes/%7Bstring%7D”,“detail”:{“errorcode”:“messaging.adaptors.http.flow.ApplicationNotFound”}}}

Whereas, if I pick another API category, say Product search, and put one of those URLs in the browser, the result is the service saying the query isn’t right (lack of a client ID, for starters):

{“ErrorResponseVersion”:“”,“StatusCode”: 400,“ErrorMessage”:“The Client-Id is missing”,“ErrorDetails”:“Ensure the X-DIGIKEY-Client-Id header has a valid Client-Id”,“RequestId”:“db4bc43a-53ad-41d1-fd74-6dd287c2f425”,“ValidationErrors”:}

Likewise, in my working product details script, changing out the product details resource URL for any of the barcoding URLs results in a 404 response followed by the same error as listed above.

I have tried playing with the URL a little bit (changing the case, changing ‘BarCoding’ to 'BarCode, removing the trailing ‘s’, etc, etc) with no luck. Just too many permutations.

Can anyone confirm this error, or am I just missing something? Could the resource URL for the barcoding APIs just be pointing to the wrong location?

Any insight would be much appreciated!
Thank you very much,


The best bet is to check the APU FAQs and if there is not help there we do have an API ticket system.



Hi Robert–
Unfortunately, the FAQ does not address 404 errors.
I have submitted a ticket as well. I was just hoping someone in the community recognized this issue and had an quick and easy fix. :slight_smile:

For anyone with this problem in the future:
The API support team got back to me and it turns out the ‘c’ in ‘BarCoding’ needs to be lowercase; ie: ‘Barcoding’. The resource URL will be/has been updated so hopefully the problem won’t happen again to anyone else.

1 Like