About disconnecting wwan0

I upgraded the kernel version of the BBB board to 5.15 and the debain version to 11.5.
And BBB is connected to LTE Modem using usb.
I succeeded in getting the ip address from the lte modem through the following command.

sudo /sbin/dhclient -v wwan0

After a successful connection, I ran a ping test with the command below,

sudo ping

but after about 2 hours, the network through the LTE modem was disconnected.
So when i check with ifconfig, no IP is found in wwan0.

If I run this command again, ‘sudo /sbin/dhclient -v wwan0’, the IP will appear in wwan0 normally,
and ping will also be connected normally.
Below is what I tested.

The files in the following path are the same for kernel 4.19 and 5.15
I don’t know why the connection doesn’t drop in 4.19, but it drops in 5.15.


I don’t know why the network through let modem is disconnected after about 2 hour.
Can you tell me the cause and how to fix it?


This is why we don’t force kernel upgrades by default, just downgrade to your previous 4.19 based kernel…