[BBB] Cellular: Ping error

I am testing Beaglebone Black with LTE modem thru usb
BBB gets IP address of wwan0 from LTE Modem.
So I can use Ethernet communication on BBB through LTE modem.
I ran the ping test for a long time to check if there was a network disconnection.
Everytime icmp_seq is around over 7000, network is disconnected.

The followings is the message of ping


IP address of wwan0 was disapeared as below

When I run the command as belows

sudo dhclient -v wwan0

The IP address of wwan0 appeared as belows

The current kernel version is 5.4.44-bone29

By the way. when I tested the same thing kernel version 4.19.31-bone-rt-r31
the ping is good even after a day.

What’s wrong it?
Could you help me solve the problem?


@taek8461, sorry there is not enough details to work with. After the connection dies, please try running “dmesg” to see if any thing useful is printed out…


I captured dmesg after the connection dided
I add dmesg file dmesg.txt (21.6 KB)

Could you let me know what is wrong and how to fix it?