Beaglebone Black DNS bug


I’ve run into an unexpected issue that seems so simple to solve yet I have been unable to find a solution.

ping localhost fails with “ping: unknown host localhost” whenever the ethernet cable is unplugged.

the loopback is up: ping succeeds.

Something about bringing eth0 up starts a dns server that is otherwise inactive.

Has anyone ran into this and aware of a solution or work-around?

Unfortunately I’m tied to an old version of debian, 7.9 and can’t upgrade due to legacy drivers that also rely on localhost rather than for some socket connections.

I have tweaked the configuration of /etc/hosts and /etc/resolv.conf to no avail, and tried static, manual, and hotplug variants of the interfaces, but this has not helped either.



What’s in your hostfile?

cat /etc/hosts

Sorry, Debian 7.x really does not get tested anymore…


I realize the 7.x is far from being supported, so I appreciate that you even responded.

I tested from a fresh install of the 7.9 image posted at the beagleboard latest images page.

I believe I also found the issue: in 7.9, the permissions on /etc/hosts and /etc/hostname default to 600 while in 7.8 and 7.11 they default to 644. After making this adjustment, ping localhost succeeds even when an ethernet cable is not plugged in.


awesome @jeff.campbell ! Looking back, this may have been when i fixed it: chroot: carpet bomb files to root:root · RobertCNelson/omap-image-builder@586c447 · GitHub 2015…