Atmel-ICE: Firmware Corrupt Bootloader

Hello so I just got the board a week ago and tried to use it for my class. However, whenever I tried to plug it into my laptop it’ll give me a driver error.
“This device is not configred correctly. (code 1)”
“A service installation section in this INF is invalid”
And whenever I try to update driver from online ill get the same error. Ive tried different ports and a different computer, none worked.

Hi @jackiegao30, which AT32UC3A board are you using? What Version of Windows (32bit or 64bit)

Edit: Removed-ed FLIP recommendation… Don’t use FLIP on Atmel-ICE, when in DFU mode, you need to stick with Atmel Studio’s driver…

Regards,

Hello, so it seems to have installed the driver but the light doesnt seem to be lighting up?

The LED light* won’t light up showing that it is powered, I was told it’s supposed to light red, but mines doesnt light up at all.

@jackiegao30, which AT32UC3A based board? Atmel made a few dozen different variations, during the production lifetime of the AT32UC3A. It’s okay, if you can’t find and ID, just can also just post a photo from the top and bottom of the pcb…

Regards,


Here’s a picture of the board

Hi @jackiegao30, UhOh! That’s the Atmel-ICE Debugger!

The drivers for that device are included in this software package:

https://www.microchip.com/mplab/avr-support/atmel-studio-7

I now have Atmel Studio installed, and i found my Atmel ICE, here is the folder location of the drivers you need to have installed:

Regards,

Hello!

I actually installed the Atmel Studio 7 last night from the recommendation of online sources, however, I dont think that seemed to work either? Unless I’m supposed to reinstall the driver or something?

image

Not sure what to do.

@jackiegao30, oh that’s going to be tricky… First click on “Update Driver”, then using the windows prompts, switch to folder mode and point to the Atmel Studio…

Give me an hour, i can do a better step by step after a meeting…

Regards,

Hello,


image
This is what I get.

@jackiegao30, using Atmel Studio’s command prompt shortcut, let’s take a look at what Atmel’s firmware tool see’s…

Please run these two commands:

C:\Users\<user>\Documents>atfw.exe -l
Connected tools:
atmelice        J41800002104
atmelice        J41800002104_01

C:\Users\<user>\Documents>atfw.exe -t atmelice -r
Found atmelice:J41800002104
Master MCU Version: 1.29

Regards,

Seems like it’s not detecting my device.
image

@jackiegao30, that’s not a good sign. I was really hoping atfw.exe would discover your Atmel-ICE. Sadly, it’s bricked. All Atmel AT32UC3A3 devices have an internal bootrom, that allows programming over USB. This is what Atmel’s FLIP software utilities are designed for, connect your new device to a PC over USB and program it.

Currently your board is in DFU mode, that’s why it shows up as an AT32UC3A3 in window 10, which means your Atmel-ICE bootloader is corrupt. Since the Atmel-ICE bootloader is corrupt, atfw can’t detect and connect to it, thus it can’t re-flash the firmware:

The command for writing the firmware from atfw is:

atfw.exe -t atmelice -a "C:\Program Files (x86)\Atmel\Studio\7.0\tools\Atmel-ICE\atmelice_fw.zip"

But this will fail, as you board can not be detected.

Regards,

Are there any possible fixes to this?

Sadly @jackiegao30, i have not found a work around. The atmelice_fw.zip archive has an encrypted application firmware, which means it’s useless. I would contact who ever you purchased it from and start a Return Process.

Regards,

Hello!

So I actually did place a replacement order on this item and it should arrive in 3 days. Do you know what caused this in the first place? How should I prevent it from happening again?

@jackiegao30, i’m not really sure. I tried bricking my unit here, by yanking the usb cable while running the atfw.exe update procedure, but it never modified the bootloader, just the application.

I’m thinking something external either zapped it, or… IDK…

Regards,