Cant log in

Hello, I havent used Scheme-it for a week or two, today when I log in the log-in screen seems to all work as expected but at the top right of Scheme-it it shows im just logged in as a guest “Welcome guest”. If I click the log-in button again it pops up a dialog that I must log-in to my digikey account which I have already done. It then just refreshes the page and still shows me as a guest. If I go to the Digikey.com home page it shows me correctly logged in to my account. Tried Chrome and Edge.

I still cant log in today. Here is a video to explain better:

@Adamw Thank you for the video with details showing the issue you’re seeing. Our team is currently working on a fix for this. You can try to change the URL to “.com” in place of “.co.nz” as a potential workaround.

Thanks, tried that already. It just redirects back to .co.nz site. Im not sure if that is because of location settings in chrome or something to do with shipping address in my account or something.

Here’s a video of trying .com instead of .co.nz:

@Adamw, This issue has been resolved and you should now be able to login to your Scheme-it account.

Thanks for the exceptional support. I can confirm it is working for me now.

2 Likes