Scheme It

Anyone having issues with the Scheme It program. It was working fine until yesterday. When I pull the program up there is no log in screen, the grid isn’t there, nothing really happens. I tried it the today same results. Tried clearing cache and cookies and using different browser.

We haven’t been able to reproduce the issue. Could you please send a screenshot of what you are seeing?

I hope you can see the image. There is no login screen. When you click on the link to try and open the program, the BOM manager briefly flashes on at the bottom and then disappears. If you click on say Diodes, it will tell you that there are 29 results, but none of the diode symbols show up, it is just blank. I had used the program Monday and Tuesday and it was fine other than it was a little slow to respond. Wednesday and today I haven’t been able to get it to work.

Any ideas on this problem?

Another screen shot when I first start program.

@jpurserjr - can you please take a screenshot of the Network tab in the inspect (dev tools) window of your browser? You can access this using F12 or right click and inspect (for Chrome browsers).

Are there any errors in the console?
Can you please share the name of your most recent project?

The last schematic I worked on was called Artesyn PS. Also GLM50B PS. The Scheme It is the only program I’m having a problem with.

Can’t really complain since it is a free program but it is frustrating, I have a lot of projects saved under Scheme-It, and now can’t use it. Not sure what to do next since you aren’t seeing the problem on your end.

@jpurserjr - You mentioned that you’ve tried clearing cookies and using other browsers. Which browsers have you had this issue on, and have you tried using incognito mode?

Google and Microsoft edge. Tried Incognito mode, same problem.

Just tried Firefox same issue

Tried another computer, same issue. Someone suggested I talk to our IT guy about it .

Finally figured out how to look at console errors. Sending screen shot.

Another screenshot

Thank you for the additional screenshots.
I will follow-up with the Scheme-it developers. In the meantime, it would be worth talking to your IT department about the possibility of the library being blocked by your network.

Thanks for all your help.

No problem! Thank you for your patients.

Please let us know if you have other questions or feedback on Digi-Key’s Scheme-it tool.