DigiKey website says I'm a robot


I’m a hobbyist who makes extensive use of DigiKey when designing electronics. You have the best parametric search. As a result, I end up buying almost all my parts from you.

Your main digikey.co.uk website has now decided that I am a robot, and is denying me access.

I get the page titled “At DigiKey, we’re big fans of Robots”, and there’s a “PRESS & HOLD” button. Every time I click it, it just goes back to the same page and tells me to try again.

If it helps, it says: “Reference ID: #3b5b44c0-241e-11ee-9bc1-8b2ccdcc389c”. Though this is not the first time I’ve seen it.

I have no idea how that button is supposed to work. Is there some magic I need to do? Does it assume that everyone has poor mouse control and/or a touchscreen, so me with my mouse that moves straight to the button and click it obviously has to be a robot, I can’t just be competent? Whatever it is, I’ve never actually managed to be recognised as human. It is also incredibly frustrating and feels like I’m being lied to, when the text says it’s going to verify me as a human and just doesn’t. There’s also no way to contact support from that error page.

Fundamentally, that Captcha does not work. Please can you use get rid of it, or at least use ReCaptcha since that is actually solvable by humans?

If you’ve fallen for a snake-oil salesman trying to tell you that their Captcha is the best at keeping out robots, please consider whether it’s actually just the best at keeping out some humans and giving them no way to contact support. Us excluded humans get counted as “robots” in the stats they’re giving you…

I’m clearly not going to give you any business while I can’t get to the site.

1 Like

Hello @jon7

Sorry you are having issues on the site. I have reached out for some support to try to get an answer. Either someone from that team or myself will be reaching out.

The prompt would seem to be requesting a sustained button press of perhaps a few seconds duration, rather than a brief “click.” Has that been tried?


Here is what I received from my web team.

“The detection that flagged these users checks that they’re using Chrome Webdriver in their browser to perform automation.”
Can the customer verify if they have a Chrome Webdriver installed?

the other day i could not pass the robot test, but finally did, today can’t. using chrome on PC both times

Welcome to the Technical Forum. I apologize you are having issues. I will check to see if I can find help . I will let you know what I find out.

You can send a message to ux@digikey.com and see if they can fix the issue.

I’m using Firefox, and I don’t have anything like that installed. It asks me this far too often, and the amount of time required for “click and hold” is too long.

Thank you for the feedback. I have forwarded this to our user experience team.

Ooooo! One of my hot buttons! The basic rules of the internet dictate that one should be able to access a web site regardless of the system used. Not supposed to make a difference whether I’m using Miscrosoft, Apple, unix, system 390 or even a dec pdp11! It is simply not acceptable to require one to use any specific browser to use a site. Especially with the amount of telemetrics involved with Chrome! I don’t and won’t have Chrome on my system. Your IT people should be ashamed!

1 Like

+1; it doesn’t make a difference whether I’m signed in or not, or whether I’ve solved the captcha a dozen times. Typical conflation of the phrases “Google Chrome” and “The Internet”.

I am having a similar issue with this “feature”, I it is getting to the point where I can’t search for parts much less place an order. I am using Chrome and Edge with nothing but problems. Lately I get stuck in a loop of “click & hold” requests that never end. I have summited several reports but nothing changes.

Hello joe3 - welcome to the Forum community. Thank you for the feedback. I have forwarded your concern to our user experience team.

I have a a large BoM that I am going through to update the quantities to get to price breaks. I get most of the way through and am presented with the dreaded “Before we continue…” captcha. I have tried many times and I can’t get past it. This is really annoying and a huge waste of my time. Please let me know how I can proceed.


The most useful thing one can do to motivate remedy is to use the feedback button
to report a website issue

include your correspondence information

and provide the Reference ID from the nuisance bot check on the following page in the feedback form.

Understood that this is a bit of a PiTA itself, but it’s the best means of generating diagnostic info and service tickets that will lead to improvement.

For what it’s worth, submissions via the feedback tab (whatever the subject) receive substantial attention if they include a correspondence address and coherently articulate a point of view.

Anonymous rants, not so much…

What in the FUX’ is going on with this ‘ROBOT’ SHYT !

I have logged into every forum and suggested that ‘DIGIKEY’ is now a bad actor/scam site. I hope you go out of businesses 10 minutes !

It woks now - it doesn’t work
The ‘test’ NEVER WORKS

Dead to me !

this is crazy. well, i can say for sure that digikey has lost my business for the foreseeable future. no more random “At Digi Key, we’re big fans of Robots” messages. mouser forever!

(and no, its not a browser issue, tried three, all up to date, windows 10, etc… this is not the first time this has happened, and i assume not the last. best to cut my losses)

Yeah, I too am getting these infuriating repetitive “hold the button down for some time” robot checks.

For heaven’s sake. You have cookies. I’m logged in. You don’t need more then ONE robot check. Your code is broken.

This is beyond frustrating. I have been fighting this for several months. I keep sending feedback however I never get a response and the web site just slows my work down to nothing. Last week I got locked into this bot message challange trying to finish up my shopping cart, and ended up having to order the parts I needed from Mouser.
Please fix this and stop with the silly excuses.

It happens to me too, even after a few minutes without closing the browser.
Please fix the problem - it’s very frustrating!!!
You are the only electronics distribution site that has this problem.
What happened to Digikey?
It was once the best site on earth for purchasing electronic components.
Now it seems to have become the worst…