EE-Wiki Artik10 broken

Hi I am new here so please forgive me. I am trying to get a couple of Artik 10 dev boards that I bought from Digi-Key, going on ubuntu with ROS and I have tried using the awesome EE-Wiki that Robert maintains. I can only get part way through as all of the sections that require pulling data from Samsung are missing since they dropped support. Is there a cached o archived copy of the samsung dependencies. Dam shame they dropped them awesome board for robots.
Thanks heaps in advance GregO.
PS: There was supposed to be Ubuntu support according to ubuntu website but even that image has gone.

Hi @GregO, yeap the Artik platform has been abandoned by Samsung…

My board’s are the office, so i haven’t had a chance to check this repo i mirrored from another user.

Please try this:

git pull --no-edit
wget -c
patch -p1 < 0001-artik10-fixes.patch


Thanks Robert
It still fails saying that it is not a git.

Can you please post your terminal message?


(base) MacBook-Pro:Artik10-GregO-Image gomond$ git pull --no-edit

fatal: not a git repository (or any of the parent directories): .git

(base) MacBook-Pro:Artik10-GregO-Image gomond$

Is it possible to just get an ubuntu 18 sd card image and flash the 1020 like a Beaglebone or a Raspberry Pi.
There was meant to be an Ubuntu Core image available but I cant find it anywhere.
I find it amazing that Samsung pulled there website and Github . It would have cost them nothing just to leave it there for we tinkerers just to be able to do cool stuff with an awesome product that they just dumped.

Hi @GregO, here is the full directions,

git clone -b v2012.07 --depth=1
cd u-boot/

git pull --no-edit artik-exynos/v2012.07

wget -c

patch -p1 < 0001-artik10-fixes.patch

PS, careful with the MacBook, HFS+ can’t handle the linux kernel source. Haven’t personally tried with APFS yet.


Thanks Heaps Robert
Worked like a charm…